Showing results for 
Show  only  | Search instead for 
Did you mean: 

EASY FIX if your printer won't turn on


SOLUTION: After a 1:57 hold time with Canon customer service.... I have the solution! (and that was 2 hours, not 2 minutes) If this is happening to you it is very easily fixed. [Removed per forum guidelines] Although I wish I could make up for my 2 + hours of time. The tech told me that when they walked into the office Tuesday morning, "the stuff had hit the fan" because this has affected many models and they don't know what caused it. Here is what you need to do to fix it:

Completely unplug your router and then turn on your printer (it won't stay on if your router is because of a linking problem with the router, that we are going to fix.)  So this is the step-by-step for the MG6620 and probably those models with similar menus, but whatever model you have just try to get to your DNS Server Setup. That is where the setting is that needs manually changed. So for the MG6620:

On the menu swipe to Setup, then find Web Service Setup then DNS Server Setup. Select Manual.  Press each set of numbers and change them all to 000 except the last set. That needs to be 001. So your DNS will look like this:  Click OK, then click No.

That's it. You should be good to print.

You are welcome!  Too bad someone at Canon doesn't just post this somewhere. Would've save a lot of people a lot of headaches, I'm sure. 





THANK YOU, THANK YOU! Your fix worked! I have a PIXMA MG7520.


Thank you!!  This worked for my MAXIFY MB2320!! I was ready to give it last rites and call it dead!!


Ha.  I didn't want to turn off my house wifi so I 'took my printer for a little ride' down to the school parking lot (I have an ac outlet in my car).  Turned it on, changed the DNS setting, drove home and viola it prints!    

Two questions: 

1. I did a factory reset so seems to me it would know nothing of my router and therefore i'm confused as to why the DNS settings would come into play at all.  any insight? 

2. Should i still do the firmware  update that Canon provided yesterday via PrinterUpdate.exe on the usb cable.   I'm tempted to leave well enough alone at this point. 


Did you end up doing the firmware update?  I too am leery about upsetting the apple cart now that I have my printer working by changing the DNS settings.


I didn’t as I felt it was back up and running on WiFi that Canon would push the fix through anyway, just like they screwed it up!

No I didn't and don't plan to unless I have more problems. For the same reason.


So the DNS     setting is presumable In the printer? OK. Good to know. When I was able to access the printer, after disconnecting from wifi, I did not see anything related to DNS...

See Sheri99’s posting on changing the DNS.


I agree - let them push the fix - until then use the DNS manual setting.

click here to view the gallery