cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon MX452 - Desktop can read new ink levels and print; BUT my laptop no longer do this??

weedkill3
Apprentice

Hello,

 

I've had the Canon MX 452 since 2013 with no problems until now.  I use it wirelessly and my Windows 10 laptop and Windows 7 desktop are connected to it.

 

Last week, I bought a OEM color cartridge.  After installing it, I can no longer print from my laptop computer?  AFter I send a print job, I get a message saying "estimated ink levels cannot be read".

 

HOWEVER, on my desktop downstairs, it has no issues reading the new ink levels? And I can print flawlessly.

_________________________________________________________________________________________

 

What I tried so far:

 

So, I un-installed the drivers on my laptop.

 

Then, I downloaded the drivers from the Canon website.

 

NOW, when I went to install them, I chose the wireless option. It couldn't detect the printer? Even after numerous tries.  The printer is connected wirelessly, or else my desktop would be able to work with it.

 

Great, so I installed the drivers using Windows 10 printer manger software.

 

AFter doing this, my laptop still can't see the new ink levels?

 

Why can't my laptop all of a sudden communicate with the Pixma 452 when my desktop can just fine?

 

Any help is appreciated.

 

Thank you.

 

I tried called Canon tech support, but they $19.99 for a  service call??

5 REPLIES 5

Michael
Product Expert
Product Expert

Hello.

 

If the ink levels are showing accurately on one computer, the issue may be related to firewall/security software on the other computer.  Try temporarily disabling any firewall programs that are running on the second computer.  Then launch the status monitor on that computer to see if the ink levels can be displayed properly.

 

If the issue persists, uninstall the drivers and remove any copies of the printer that are showing in the Devices and Printers section of the Control Panel.  Next, reinstall the MP Drivers from our website which are available here.  If the MP Driver installation cannot automatically detect the printer on the network, try using the IP address method during the network detection phase of the install.  You can obtain the IP address by printing a network information page from the printer.  Details can be found here.  If the setup can complete, try viewing the printer status again to see if the ink levels appear correctly.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Yes, I did shut off all firewalls.

 

The problem still persists.

 

This is very frustrating. I've vhanged ink before, always using OEM, and I never had an issue.

 

IDK why my laptop can;t communicate with the printer.

 

 

 

 

 

ANother problem, when I click on the driver to reinstall, it doesn;t give me the option to input the ipaddress? It says can;t detect printer on network, go to USB, but I no longer have a USB connector. I got this printer back in 2013.

 

How do input the ipaddress?

 

 

 

 

Oh I printed the LAN paGe, which do i input?

 

There is:

 

IPv4 IP adress: 192.168.1.45

IPv4 default gateway: 192.168.1.1

 

Subnet mask: 255.255.255.0

IPv6 IP adress: FE80:0000:0000:0000:1A0C:ACFF:FEF7:9909


@weedkill3 wrote:

 

Oh I printed the LAN page, which do i input?

 

There is:

 

IPv4 IP adress: 192.168.1.45

IPv4 default gateway: 192.168.1.1

 

Subnet mask: 255.255.255.IPv6 IP adress: FE80:0000:0000:0000:1A0C:ACFF:FEF7:9909

 


Greetings,

For now, the IP of the printer is 192.168.1.45

 

The gateway address is the IP address of your router on your LAN.

 

Here is something you can do to troubleshoot.  Open a browser and type the printers IP address, press enter.  This should open the printers webserver.  You should be able to see the ink level, etc there.

 

Keep the following in mind.  The router has assigned 192.168.1.45 to the printer.  If the printer is turned off, not used or goes to sleep for an extended period of time, the router might and could think the printer no longer exists on your network.  It might then reclaim the IP it assigned previously (x.x.45) and hand it to another device requestng connection. 

 

This is not something to do with Canon (specifically), its how router's manage the pool of address' they hand out to devices that connect or in some cases "come and go" from your network.  Like your cell phone for example, that leaves your network everyday when you go to work and return. 

 

What I recommend it that you assign a static IP to the printer.  This can be a reserved IP or one that does not reside in the pool of address' your router keeps available for devices requesting connection to your network. 

 

The static or reserved address never changes, regardless of when, how often the printer is used, turned off, etc.  This way devices on your network, phones, computers, etc can always "find" the printer at its static or destination IP because it never changes.

 

Not reserving or using a static IP means the IP address of the printer might change.  Then, when you try to print, the job is sent to a destination that might be incorrect or no longer exist.  The good news.  A static IP only has to be set up once.  Moving forward you'll always know what IP to use for your device.   

 

 

 

 

~Rick
Bay Area - CA


~R5 C (1.0.7.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Hi, I loggen into my router seetings and ip changed to 192.168.1.29

 

So, on my Desktop, i typed that ip adress in my browser..........no problem communicating with the printer.

 

Again on my laptop, it cannot find the printer??

 

I have no idea why? All firewalls are off.

Avatar
click here to view the gallery
Announcements