Showing results for 
Show  only  | Search instead for 
Did you mean: 

Call to Arms for the dreaded U052 Wrong Printhead Error


This is a "call to arms" for all of you Canon customers who have had this problem and have had their printers disabled because of it.  Please respond with the model of your printer and if you were able to fix it, what you did to fix it. 


We need to put pressure on Canon to respond this product defect.  It appears to be bad firmware that does not allow the user to override the problem and to continue to use the printer even in a degraded mode.  From my investigations the problem is NOT a printhead issue - no way one can be printing fine and then have this error alert without having changed the printhead or ink cartridges!


Canon, PLEASE take this issue seriously and provide a solution across the affected models.  If nothing else there should be a trade-in allowance for those printers that have been affected by this product defect.


I have had many Canon printers because they have superior functional specifications. I want to be able to continue using Canon products but only if I can have confidence that this product defect will not destroy my investment.


If Canon is unresponsive our next step should be to aggressively publisize this product defect on social media and on major product vendor outlet sites as negatives reviews.


Forum Users, please reply with your affected model number(s) and with details of any succdessful fix procedure.

1,478 REPLIES 1,478

I am in the UK.


There has been no publicity here about this issue. I only found out about it by googling the error and came upon this forum.


My guess is that unless Canon get very much more bad publicity than they have so far, they will do nothing.


Why should they? It's probably affected their business hardly at all.

I tried to inform the Consumers Association ( Which) who still show Canon printers among their best buys with zero effect

That's really bad.


I thought about writing to the consumer sections of some of the papers, eg the Guardian, but haven't had time.


My MX850 just gave me this error and I can't get it fixed..... I trried this and even left the printer off for 15 min unplugged.....

I too just got this error, while printing out documents for a presentation.  I had to cancel the presentation/sale because of this.  I have a Pixima MX882 and when I called cannon about the issue, all they said was we can sell you another printer.  I do not want to buy another printer, especially if what you are selling breaks down when you need it most.  I will be moving to another company.

So I come to find out that my wife was using my computer last night and the printer notified her that it needed a firmware update on the LCD screen. Not wanting to wake me she accepted it. Now we have the u052 error to where we need a new printer when there is nothing wrong with it. That is ABSOLUTELY CRIMINAL Cannon. I will never purchase another product from you and hope you go bankrupt because of these actions.

That's very interesting, as that does definitely seem to indicate that it is something in a Canon  firmware update which is the cause (deliberate or not) of this error message.

I registered and never got a notice either. Is there another class action happening?

As I now have a useable Epson printer I decided to have a play with the useless MX700. I found the service manual and tried out the method of placing the machine in service mode. This was successful but it would not show it in idle mode but at least it appeared to be allowing some access to adjustments. I tried to get it to produce a test print but although it fed the paper through it didn't print anything. Anyway the manual shows how to dismantle the thing so I may do that, it will fit better into the rubbish bin.

Just had this error on my PIXMA MG8220 after replacing the large black cartridge.  Tried reseating cartridges, replacing cartridges, powering off and letting it sit, cleaning the print head, etc.  Tried to find out how to do a hard reset but could not find out how.  I am a persistent guy so I kept trying.  I was thinking that you need to get the system to forget or reset it's knowledge of the print head.  What better way than taking it out and starting the unit?  


I FINALLY FIXED IT AS FOLLOWS...I pulled the print cartridges and then pulled the print head.  I then powered it down and unplugged it.  I then went through a series of off and on and adding one piece at a time to see how the system responded.

Added print head, turned off and then on, got some error.

Added yellow cartridge, turned off and then on, got U051 error I think.

....until all were in and the unit was responding properly.

Took some time to prime since I had cleaned the print head but ultimately it worked.


Hopefully it helps in some other cases.  I was relieved to know I did not need to replace my printer due to some stupid error.



click here to view the press release