Showing results for 
Show  only  | Search instead for 
Did you mean: 

Using Digital Photo Pro for Mac with Photos on an External Drive


About a year ago, I installed DPP onto my Mac.  The program opened just fine and the file menu could "see" my Mac's my external drive where my Photos Library was located, but was UNABLE to display thumbnails or allow me to open an image.  At the time, a Canon rep told me that DPP was not designed to work with a Photos Library on an external drive.  I found this hard to believe, given how many folks keep their photos on external drives.

Has anything changed in this regard with newer versions of DPP?





Not exactly the same problem but recent problems with DPP on finding files at locations other than the Macintosh HD.  I haven't tried an external drive w/DPP but if I see different behavior than you, I'll let you know.


Macbook (Ventura 13.2.1) and DPP4 (Version 4.17.20... - Canon Community


Long shot, but perhaps this is due to incorrect privacy settings?

While I don't have DPP, I did need to adjust settings for various apps such as Adobe Lightroom to ensure that all my removable volumes were accessible to it.

The following notes are for macOS Ventura (13.x), but there are similar settings in prior OS versions.

  1. Launch System Settings
  2. Open the Privacy & Security panel
  3. Select the Files and Folders item
  4. Locate the apps you need to check in the list and click on the disclosure indicator to reveal the individual settings.

Example from my settings regarding Adobe Lightroom:



EOS 5D IV, EF 50mm f/1.2L, EF 135mm f/2L, 600EX-RT (x6), ST-E3-RT
EOS C70, RF 24-70 f/2.8L IS, EF-EOS R 0.71x

I never thought of that.  I'll give it a try.  Thanks!

I do not have options to select anything other than the top three for DPP (Desktop Folder, Documents Folder, Downloads Folder).  My Adobe products do have additional toggles for other locations including Removable and Network Volumes.

I wonder if you could add DPP to the Full Disk Access permissions:

  1. In the System Settings application, select Privacy & Security
  2. Select the Full Disk Access item
  3. Scroll to the very bottom of the list and click on "+" (you'll most likely be challenged to enter your password).
  4. Once you unlock the settings, you should see an Open dialog to choose an application (should default to your Applications folder).  Select the DPP app.
  5. Once you add DPP to the Full Disk Access list, you may then need to ensure the switch next to that item is turned on.

EOS 5D IV, EF 50mm f/1.2L, EF 135mm f/2L, 600EX-RT (x6), ST-E3-RT
EOS C70, RF 24-70 f/2.8L IS, EF-EOS R 0.71x

I don't mean to hijack this discussion.  

Have tried Full Access previously but just did it again.  No luck w/DPP recognizing anything other than the Mac HD.  Appreciate the help.



Full Disk Access trick worked for me! Thank You!!!!!!!!!

Rising Star

I hope some of this might be helpful. I have a 2019 iMac running Ventura 13.2.1. I have upgraded the RAM to 96 GB and that seems to me to speed up file access by caching.

I have noticed with the newest macOS some permissions are only set at software install and not available in the settings menus later if on an Intel CPU instead of Arm64. Sometimes it works to delete the software, download it again, and install it again.

For me, privacy and security -> files and folders -> Digital Photo professional
has enabled "Desktop Folder", "Documents Folder", "Downloads Folder", "Network Volumes", and "Removable Volumes". I do not have full disk access enabled for DPP.

Access to network volumes is very slow starting up probably because I have disabled Finder indexing of network volumes.

macOS is only willing to access a few types of file systems without third party drivers. My network drives are attached to a Debian Linux computer and shared via SMB. NTFS file systems for example do not work with macOS without a 3rd party driver. Some types of FAT file systems also do not work.




I saw a few questions about access when I first downloaded, as someone else mentioned, and I guess I should have checked those boxes but I did not. I thought I could correct later in preferences, cannot find. Do I really have to delete, and redownload?