cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Trouble Connecting EOS R8 to EOS Utility on a Mac

tjdowling
Contributor

I am having issues connecting my R8 to my Mac via the EOS Utility. I have the latest software and have gone through the user manual. The message I keep getting is:

"Communication with the camera via USB cannot be established.
Start EOS Utility after closing all the apps that communicate with the camera, and then turn on the camera again."

I am unaware of any apps that I have that would be trying to communicate with my camera in the background. Anyone know what's going on? Thanks in advance.

1 ACCEPTED SOLUTION

jrhoffman75
Legend
Legend

@tjdowling wrote:

I am having issues connecting my R8 to my Mac via the EOS Utility. I have the latest software and have gone through the user manual. The message I keep getting is:

"Communication with the camera via USB cannot be established.
Start EOS Utility after closing all the apps that communicate with the camera, and then turn on the camera again."

I am unaware of any apps that I have that would be trying to communicate with my camera in the background. Anyone know what's going on? Thanks in advance.


It is a problem that seems to have developed with the 13.4.1 update to Ventura.

I was able to sync my 1D X MkIII prior to that update and now I get that error.

If you are only looking to download images you could get a card reader. If you are wanting the tethering features then we have to wait for Apple to fix the problem.

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic

View solution in original post

50 REPLIES 50

Anonymous
Not applicable

Make sure that Wi-Fi and Bluetooth are turned off in the camera in order to use the USB cable.

tjdowling
Contributor

No luck

Anonymous
Not applicable

Are you using the USB cable that came with the camera? If not, make sure that the cable is a data cable and not a charging only USB cable.

Also, what is your Mac operating system version? Someone else here will have experience with a Mac, as I use a Windows computer.

Yep - the one that came with the camera.

MacOS Ventura.

Maybe this is a privacy & security issue?  On your Mac, launch System Settings and then choose Privacy & Security.  Scroll through its settings and see if there's anything related to attaching accessories.

This Apple Support article has some details.  

--
Ricky

Camera: EOS 5D IV, EF 50mm f/1.2L, EF 135mm f/2L
Lighting: Profoto Lights & Modifiers

This is appears to be a setting only on Mac's with the M1/M2 chip. I have an Intel Mac and don't have the setting. Good suggestion though. Thanks.

Anonymous
Not applicable

If you are just trying to transfer pictures to your computer, you could remove the memory card from the camera and use a card reader to transfer the files.

jrhoffman75
Legend
Legend

@tjdowling wrote:

I am having issues connecting my R8 to my Mac via the EOS Utility. I have the latest software and have gone through the user manual. The message I keep getting is:

"Communication with the camera via USB cannot be established.
Start EOS Utility after closing all the apps that communicate with the camera, and then turn on the camera again."

I am unaware of any apps that I have that would be trying to communicate with my camera in the background. Anyone know what's going on? Thanks in advance.


It is a problem that seems to have developed with the 13.4.1 update to Ventura.

I was able to sync my 1D X MkIII prior to that update and now I get that error.

If you are only looking to download images you could get a card reader. If you are wanting the tethering features then we have to wait for Apple to fix the problem.

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic

Sounds like either Apple or Canon would need to provide the solution via an update of some kind and I'm not banking on the speed of Canon updates...

Avatar
click here to view the press release
Announcements