Showing results for 
Show  only  | Search instead for 
Did you mean: 

MAC-EOS Ver 30.2 Solution Disc will not install


Im running a macbook pro with the latest OSX update 10.10.4 and have tried installing the Ver 30.2 Solutions disc that came with my 5DS ....and it won't install. I click on the set up Icon and it bounces in the dock then dissapears and that's IT .....

I have tried the same with the download from canon and its the same deal.


Is this happening to anyone else .....



I have exactly the same problem. I sent support tickets to Canon Professional Services and their response was that I was not using the correct app to mount the DPP. But I was using the correct app, namely DiskImageMounter.  I click on the installer and a prompt says "Extracting..." but then there is a hangup and nothing happens. There obviously is a problem with the software, and Canon is not addressing it.

Yep , The only way to get around it is to open the installer on another computer running an older OS then transfer it via a usb drive . 

I use capture one for my processing software , it now works with the 5ds . 

Thanks for the work around. I've tried it on a MacBook with Snow Leopard but it was a no-go. I'll try it on my wife's MacBook with Mavericks.


Anyway, Canon Professional Services said they would be sending me a CD with the DPP on it. I'm happy they are doing that, but I'm not holding my breath. We'll wait and see. To be continued...



Having Snow Leopard (OS X 10.6) is likely a problem.  You're trying to install new software on a very old operating system version.  I find that software written for 10.8 will usually work on 10.9 and 10.10... but 10.6 is old enough to have some significant differences and will likely have compatibility issues.


If your computer has a 64-bit Intel processor then it can be updated to 10.10 (and OS updates from Apple are all free.)  While most new computers tend to have an Intel i5 or i7 processor, I still have a very old MacBook Pro that only has an Intel Core2 Duo -- and even it can run 10.10.


Tim Campbell
5D III, 5D IV, 60Da

Hey Tim 


The problem seems to be OS 10.10.5 . The installer "Stalls" , it will work with earlier OSX.

I'm running OS 10.10.4 where the problem has existed from the get-go. In other words,  Canon software does not work with the latest Mac OS, period! The issue is not Snow Leopard or any other earlier Mac OS. The issue is that for some reason Canon software is not working with the most current version of Mac OS. I'm not a techie, just a practitioner, but them are the facts. Thanks for all the feedback, nonetheless. Maybe Canon will listen/read, and recognize the problem!

When you say it "stalls" I might need a rundown of your steps.

I did test a few things on my own with two of my Macs. I noticed that one of the apps (just one) wants to install Microsoft Silverlight. Since my Mac doesn't have Silverlight, it acts like it's going to go download and install it -- but it doesn't. The installer will hang on that particular app (and I don't recall which one it is.)

SO... as a test, I manually downloaded and installed Sivlerlight from Microsoft's website and THEN restarted the installer. When I do this, it runs through the full install and everything completes fine.

You might give that a shot. Let me know if that solves it.
Tim Campbell
5D III, 5D IV, 60Da



Thanks for taking the time to trouble shoot the install issue.


I'm on a Mac Pro (late 2013) running OS X Yosemite (10.10.4). I downloaded the Microsoft Silverlight (Vers. 5.1.40728.0) as you suggested, and tried installing Canon software "dppm4.3.0. The same problem arose as before, namely, I got a Canon install screen with an image of a DVD with a blue downward pointing arrow, which was titled "dppm4.3.0-installer". When I double clicked this image, another screen showed an "installing" notice, then it disappeared and nothing happened.


I even started in Safe Mode, and the problem persisted.


Since some Mac OS's are able to handle the install but not the lastest OS says something. Ususally if a current new software does not work, it is with earlier OS's, not the current one.


A puzzlement!?

You may be running into the Apple security feature that blocks software from being installed unless you approve it.


Go into "System Preferences"  (on the menu bar, click the black apple  and select "System Preferences..." from the pulldown menu.


Within "System Preferences" select the "Security & Privacy" icon (it's in the top row).


Within "Security & Privacy" select the "General Category"


Near the bottom, select the option which says "Allow apps downloaded from:" and choose the "Anywhere" choice.


NOTE:  If the padlock icon in the lower left corner is shackled closed (locked) you will need to click the padlock and type your password to unlock the panel.  Otherwise it will not allow you to make any changes.  


The panel should now look like this:


Screen Shot 2015-08-28 at 4.46.48 PM.png

Now open the Canon disk image file for the installer (i.e. I'm opening the one named "EOS Solution Disk 29.1A" but Canon updates these frequently so your version number may be newer than mine.)


You should now have a window that looks like this:


Screen Shot 2015-08-28 at 4.48.35 PM.png

Double click the installer icon (in this case it's named "ksd291a_installer" but that's because this is the version number of the EOS solution disk.  If your download is newer then the version number may be different.


This may (and probably will) cause a window to pop-up which looks like this:


Screen Shot 2015-08-28 at 4.49.56 PM.png

Again, this is Apple's security trying to make sure you don't accidentally fall for some trick by a malicious party trying to trick you into installing malware on your Mac.  Since we trust Canon and we know how this software ended up on the Mac, it's safe to click the "Open" button.


You should now see a window that looks like this:


Screen Shot 2015-08-28 at 4.51.19 PM.png

From here, you probably want to click the USA, Canada, & Latin America button, and I seem to recall the next panel asks you the country/region (most likely you'll pick United States) and from there I think you'll get the window asking if you just want to install everything or if you want to customize (in which case you can pick and choose which components you want to install.)


I DO RECOMMEND that you return to the security panel and set the security preference so that it no longer trusts software from "Anywhere" (I set mine to "Mac App Store and identified developers") as this will make it more difficult for malicious parties to trick your Mac into installing malware.  Yes... it does mean that if you try to install software from a party that doesn't have an Apple software signing certificiate then you'll have to go through this process, but the added security makes those few steps a worthwhile investment of your time.


Good luck!


Tim Campbell
5D III, 5D IV, 60Da
National Parks Week Sweepstakes style=

Enter for a chance to win!

April 20th-28th