Showing results for 
Show  only  | Search instead for 
Did you mean: 

M50 Mark II with 1.0.4 Firmware


Hi Canon Community,

I recently purchased a Canon M50 Mark II and it comes with 1.0.4 firmware.  I noticed that Canon US has up to the firmware 1.0.3.  How it this possible? I did my research and it looks like that firmware exists in SouthEast Asia?   I have heard that this happened to other people even when they purchased from a certified dealer.  Please, anyone, I need help to make my camera work.   It is not being read by my Mac M1.  Can I downgrade to 1.0.3?  How can I solve this issue, I will mainly use the camera for livestreaming, using it as a webcam.  Please help.  THANK YOU!



Some cameras have newer firmware than publised. M50 II and 5D IV for example. No need to downgrade.

Hi Peter,

The problem is that it cannot be recognized by my computer because there are no EOS drivers, utilities etc. because Canon only offers software for 1.0.3.  My intention with this camera was to use it as a webcam and it is not being recognized.   I need to use my camera with my computer.  

Did you get an error message about wrong firmware?

No error.  However, when I tried using it for Zoom, OBS, etc, these would not see my camera.  I have an M50 (not a Mark ii) and I have no problem with it (except the M50 has many limitations, the reason I acquired the Mark ii) because I have the right drivers for that camera.   But because cannon only offers drivers up to 1.0.3, I am at loss with this camera with 1.0.4 firmware. WHY would this camera have this non-existent firmware on Canon's site?  How do I get it to the useful 1.0.3?  Thank you! 

You can probably downgrade by just installing 1.0.3.

The camera would not let me downgrade. I tried via the computer, and some tricks I found for other cameras online... nothing

I called Canon and I was told that sometimes the cameras are sold with upcoming firmware, and I just have to be patient until it is out. It may take months for this.  I was told to try downloading the firmware for the previous Mac Version ( I have the 13; dowloaded the 12), it did NOT work.  I tried my Windows lap and the latest firmware available on Canon's site is talking to my camera.  Unfortunately, that is not my main computer, but I have hope that in a few months I will be able to finally use my camera for what I purchased it for.   Don't know why Canon does that when it would not work with previous version firmwares.  Makes the camera useless for months!

Thanks for all your support, Peter.

You tried via Eos Utility to downgrade?

Have you installed version 2 of the EOS Webcam Utility? That's the only version that's compatible with M1 Mac. You will have to manually select macOS 12 if you're running macOS 13. You can get the software from HERE




I'm sure there is nothing wrong here worth getting worked up about.

Where are you located?

Did you buy your Canon product from an authorized Canon Dealer?

What Peter said was true.  Canon might have released a newer FW on the device you purchased, nothing to be concerned about.  This is normal.

Do not try to downgrade your FW, this could potentially brick your camera.  Canon Asia only has v1.0.3 also.


You will not gain any functionality with FW v1.0.3.  The issue you are describing probably lies with your MAC.

This is what I would look at:

Are you using an older version of the WebCam Utility (As Stephen pointed out).  You should be using v2.0

Verify/Confirm Ventura's new security features.

-USB connections are allowed

-GateKeeper is not blocking the WebCam Utility

Grant the WebCam utility Full Disk Access

-Disable the firewall while you troubleshoot

-Disable or uninstall any 3rd party AV software if present

Ventura has been a little sketchy, even 13.01 (latest as of today).  I have not used OBS, but Zoom has a ARM specific download for Apple Silicon.  Keep the following in mind.  No other streaming apps will work until you get the camera to detect in the WebCam Utility.  Have you tried another USB cable?  Tested on another computer?  Start ruling things out one by one.  I'll bet you discover the issue.

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It