Showing results for 
Show  only  | Search instead for 
Did you mean: 

FIXED / SOLVED: Problem to use EOS Webcam Utility with Big Sur on Mac and Canon EOS R5 with TEAMS


FIXED / SOLVED: Problem to use EOS Webcam Utility with Big Sur on Mac and Canon EOS R5 with Microsoft TEAMS


Since updating from Catalina to Big Sur I had the issue, that EOS Webcam Utility didn't work anymore with Microsoft TEAMS. The Virtual Webcam did not appear as available camera in TEAMS. So I found the following solution from  Glen Aspeslagh (thank you very much Glen for sharing this to us!) and it worked PERFECT for me. After removing the virtual camera blocking from TEAMS by using the Terminal code from Glens Website and Restarting TEAMS I can now choose my EOS R5 as webcam via EOS Webcam Utility on my MacBook Pro 16" from Late 2020 with TEAMS. 
Before the removement from the Virtual Camera Blocking I could not use my R5 in Chrome Browser as webcam.

Follow these easy steps to solve the problem:

1. Close your TEAMS App on your local Mac machine
2. Copy this Terminal Code:


sudo codesign --remove-signature "/Applications/Microsoft Teams Helper (Renderer).app"

3. Start your Terminal App

4. Paste the Terminal Code

5. Insert your Mac-Adminpasswort (you wouldn't see anything while typing the password)

6. Confirm by hitting the Enter-Key

7. Restart TEAMS and after that you will be able to choose EOS Utility as Webcam Input

8. Connect your EOS Camera via USB-C Cable to your Mac

9. Enjoy perfect webcam quality on your TEAMS Videomeetings! Smiley Happy


I hope this will be helpful for you too! 

(Perhaps someone can find a similar solution for ZOOM too and share this here on the community forum.)






This will unsign the application which will probably lead to issues going forward.   There's a reason application's are signed.


Camera: EOS 5D IV, EF 50mm f/1.2L, EF 135mm f/2L
Lighting: Profoto Lights & Modifiers


I used the code and it didn't work.  I now don't have access to my Canon M50 on Zoom or Teams.  How can I reverse this command?

Since the newest Update this Code snipped doesn‘t work anymore. (You can find an updated version of this code snipped on different webblogs. I’m sorry, that this solution brought you problems, for me with it works for the moment). By reinstalling teams and zoom the problem should be solved.

Worked a treat, thanks for the share!