Showing results for 
Show  only  | Search instead for 
Did you mean: 

Error: "Please update your device's settings to accept media transfers"


I recently started seeing this message in Windows 11 Photos, which I have seen before, but now I can't move past it.  I am trying to transfer photos from my SanDisk to the laptop.   I think it may have something to do with Canon software, which I recently downloaded.  I can transfer to my just fine using bluetooth/WiFi.   Anybody have a suggestion?



Problem solved.   Somehow I had begun recording all photos to card#2.  As long as I have owned this camera, I had never used card #2 and I do not recall making this change.   But, my normal card 1 was indeed empty, but when I connected via bluetooth, everything showed just fine.   I ordered a new card reader, but my existing card reader works fine, so I'll probably be returning it.  Simple solution, just took me about 2 weeks to figure it out.  Thanks to those who tried to help me figure this out.  

View solution in original post



Tell us what you’re doing.  What camera?  Are you using a card reader?  

Are you trying to connect to the camera with a USB cable?   And, then move the files?

"The right mouse button is your friend."

I’m attempting to download photos to my laptop using a USB card reader - I have an R7.  

Why not just copy the files to a folder on your computer using File Explorer before opening in Windows Photos?

Canon 5D Mark IV / 5D Mark III / 6D / 80D / Speedlites / Lenses

I tried this - the two folders DCIM and MISC, and the subfolders under DCIM (100EOSR7 and CANONMSC) show empty, when I know I have photos on the card.  

If you can see those folders in File Explorer, then you should be able to see the picture files in them. What type of picture files are on the card? JPEG or RAW?

Canon 5D Mark IV / 5D Mark III / 6D / 80D / Speedlites / Lenses

.JPG files  - and yes, I ought to be able to see the files in explorer, but I don't  -    I am starting to think I have a bad card reader   ...

Sounds like you may be right about the card reader (or cable).

Canon 5D Mark IV / 5D Mark III / 6D / 80D / Speedlites / Lenses


Actually, I would question whether it is the camera.  How good are you at updating the Windows software?  There have been a slew of updates over the last wee while, some of which are to do with connectivity security.

cheers, TREVOR

Before you ask us, have you looked in the manual or on the Canon Support Site?
"All the beauty of life is made up of light and shadow", Leo Tolstoy;
"Skill in photography is acquired by practice and not by purchase" Percy W. Harris

My windows software is up to date.   And the Windows help that seems to be the closest to my situation is designed for phones and indicates it has to do with USB settings.  I don't find any similar choices on the R7: 

Note: If you're using an Android phone and Import isn't working, you might need to change your phone's USB setting to allow it to transfer photos.