Showing results for 
Show  only  | Search instead for 
Did you mean: 

Eos Utility problem


Hi to all,

I have a problem with the Eos Utility Software.

I have the OS Windows 8, and I installed the last version of EOS Uility 2.12 compatibility with the new OS.

When I connect my EOS 5D MKIII or the 7D the EOS Utility not recognized the camera.

The drivers are installed , all the others programs works fine with the cameras.

Someone have a suggestion ? Smiley Happy


I was having the same issue with EOS Utility not seeing my D60.
In Device Manager, do you see any other devices other than your camera under "Portable Devices"? Under mine, I have listed 4 removable media drives "SD, CF, etc.) that corresponded to my All-in-one Internal USB2.0 connector Card Reader. Each slot is shown as a drive letter. I disabled all four drives by right clicking each one and choosing "Disable" Once that was complete I plugged the camera back in and started the Eos Utility. Camera was now fully recognized. I can still use the media slots even with each drive being disabled.
Good Luck

View solution in original post

132 REPLIES 132

I got this same problem. I uninstalled from the device manager and restarted then it worked.

I tried your suggestion and it worked with the older version Tested the 50D with this version and it works fine. Upgraded to 2.12 and the 50D works still. Tried the 5D mark II and not working. Have made some progress in that the 50D (my spareSmiley Sad camera) works.

We are not aware that there are issues with drivers within Windows 8.  I will escalate this issue and the supporting documentation to our engineering staff.  Again, we apologize to anyone who has been inconvenienced by this issue. 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.



Refer to the following link where I created a thread and in tat thread almost everyone confirmed that there are issues with EOS Utility not detecting Cameras on Windows 8, particularly 64 bit OS.


If we install same software on Windows 7 and connect camera it immediately detects. It looks like the drivers for EOS Utility are not supported in Windows 8 - 64 bit.


For example, in my system I've more than 20 USB Ports (2.0 and 3.0) and I tried all the ports and Windows 8 detects the camera, 7D and 5D M3 but when I open EOs Utility, there Download images option is greyed out because EOs utility fails to find any camera irrespective of to which USB port Camera is connected.



We are not experiencing the same issue with our own computers, so this may be something that is isolated to your computer, as well as some others.  We do not commonly hear about this issue, but we would like to see if we can help you to resolve it.  Please contact us directly using this Contact Us link.  This way we can gather some more information from you and hopefully we can resolve the issue or at least determine what is causing it.



Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

I've had no success with two Win8 systems.  The drivers appear to be installed correctly, the camera shows up in the device manager under "portable devices" and via Windows explorer I can transfer files as if it was a flash drive.  Is this where it should appear in the device manager tree?   I have uninstalled / reinstalled all Canon applications and still EOS utility does not recognize the camera.  I'm a software developer, have written drivers etc for Windows, but I have no way to know why EOSuitility cannot see the driver.  As I mentioned above, the original developers in your company need to investigate since they do have the tools to figure out what's going on.  if you're successful in getting any of these people going, I do hope you'll post the method here.


Here are several other threads you should read, which illustrates how widespread the problem is.




Got it to work. Uninstalled EOS Utility, installed latest version. Plugged 5D mark II in. When screen came up with TAP TO CHOOSE WHAT HAPPENS WITH THIS DEVICE...scrolled to bottom and told Windows to take no action. Opened EOS working!!!Smiley WinkSmiley Happy

I was able to make EOS Utility work on my system by uninstalling another driver (WD20EARS, an esata disk drive)  that was appearing in the Device Manager section "Portable Devices".   Then EOS utility recognized the camera.  I then right-clicked on the computer icon at the top of the Device Manager tree and selected rescan computer, which reloaded the driver I uninstalled, along with three unsuccessful driver loads for "WPD File System Volume Driver" which could be the key to undersanding the EOS utiilty / Win8 problem on some machines.  I then hooked up another camera, a 5D Mark II EOS Utility didn't recognize the new camera (but the Mark III continued to work).  I repeated the uninstall of the WD20EARS disk drive, and then EOS utiity recognized the Mark II camera (and the Mark III still works).


FWIW The esata drive still continued to be readable even when I deleted it from the Portable Devices section.


Also, I got this idea from posts on by Ron Hu and user 1S74 who wrote about  deleting other USB drivers (1s74), and unplugging external USB card readers


Good luck Canon figuring this one out, it's a bit convoluted!




working eosutility.png

I am also getting similar problem and I don't think people who have posted at several thread are wrong. Definitely there is an issue with EOS Utility.


See screen shot of my system.



Justwildlife - if you want to check the device manager to see if you also have extra devices like I did, you can get there a few different ways.  If you have a standard win7 looking desktop with a "Computer" Icon you can right click on that, select properties, then look for Device Manager in the upper left and click that. 


From the new Win8 start screen, it appears you first have to go to your desktop first.  If there's no Computer Icon,
then I think you have to right click on a desktop area with nothing else there, select personalize, then select Control Panel Home, then Device Manager.  (Thanks for making it easier for us Microsoft)


Then in the device manager, scroll down and click on Portable Devices to expand that part of the tree and see what's there.  To blow something else away, right click on it and select uninstall.  Don't worry, you can get it back as I describe above by going to the top of the tree, right clicking on the computer name and selecting "scan for hardware changes".


After your uninstall anything else there, then plug in your camera and try EOS utility.

click here to view the gallery