Showing results for 
Show  only  | Search instead for 
Did you mean: 

Eos Utility problem


Hi to all,

I have a problem with the Eos Utility Software.

I have the OS Windows 8, and I installed the last version of EOS Uility 2.12 compatibility with the new OS.

When I connect my EOS 5D MKIII or the 7D the EOS Utility not recognized the camera.

The drivers are installed , all the others programs works fine with the cameras.

Someone have a suggestion ? Smiley Happy


I was having the same issue with EOS Utility not seeing my D60.
In Device Manager, do you see any other devices other than your camera under "Portable Devices"? Under mine, I have listed 4 removable media drives "SD, CF, etc.) that corresponded to my All-in-one Internal USB2.0 connector Card Reader. Each slot is shown as a drive letter. I disabled all four drives by right clicking each one and choosing "Disable" Once that was complete I plugged the camera back in and started the Eos Utility. Camera was now fully recognized. I can still use the media slots even with each drive being disabled.
Good Luck

View solution in original post

132 REPLIES 132

@I wrote:

@Skirball wrote:

No, version 3.0 is in some sort of "pre-launch", where it's currently only compatible with their full frame cameras.  Not even the new 7d2 works with it, yet.  Canon hasn't indicated when it's going to be updated to work with older models.  Stick with the latest 2.xx version for now.

I sure hope that "yet" is the appropriate word. So far, Canon has said nothing to counter the idea that they consider the new versions of EOSU and DPP to be special perks for FF users only. This is particularly tough for those of us who have both crop and FF cameras, because neither version of DPP tells you whether the other version has edited the image file.


EOSU ver. 3 seems OK so far, but ver. 4 of DPP is nowhere near ready for prime time. It has some nice new features though.

Here's an example of how unready DPP4 is: I have pictures from a family event, some taken with my wife's T2i and the rest taken with my 5D3. If I'm in DPP4, I can't even sort them by shooting date & time, because DPP4 can't (or won't) read the T2i's Exif data. Which means I can't renumber them consecutively in DPP4. Fortunately, I can do it in DPP3, because DPP3 understands the Exif data from either camera. But I shouldn't have to. And this is in addition to the craziness of arbitrarily restricting DPP4 to FF cameras. And they're not inconveniencing just amateurs; surely plenty of pros and semi-pros have both 5D3's and 7D's.


The bottom line is that either Canon appears indifferent to the needs of those who have both FF and APS-C cameras or they failed to think through what they were doing. If I were Canon, I'd find either explanation embarrassing.

Philadelphia, Pennsylvania USA

I also have this problem on Windows 8.  My EOS 70D is not recognized by EOS Utility, but it is recognized by Windows as "Canon Digital Camera".  I have used Remote shooting with this computer (and same Win8 installation) many times before, but after installing the update, I cannot use Remote Shooting any more.


When I open "EOS Utility", I get the screen that tries to connect to the camera over wifi.  My camera is plugged in via USB, so I don't need wifi.  When I bypass the launcher by opening "EOS Utility 2", the first three option are greyed out (including "Camera setting/Remote shooting"), and the only available option is "Monitor Folder".


I have uninstalled the new version, reinstalled the old version, reinstalled the new version, deleted and reinstalled the driver in DevMgr, restarted, etc etc etc.  Yes, I have the USB cable plugged directly into my computer.  Yes, I have tried all USB ports.  Yes, I have tried other cables.  Yes, I have disabled antivirus.  Yes, I have patted my head and rubbed my tummy while installing.  I have tried everything, and EOS Utility simply DOES NOT WORK!


This is ridiculous. I have a paid gig in two weeks which REQUIRES live remote shooting, and I don't know what the heck I am going to do if I don't find a solution.


Canon, PLEASE help!  Do something!  There are people all over the world having problems with this, so please come up with a better answer than "reinstall the software."

Well, how about that?  After venting my rage, I decided to keep trying new things and came up with a solution that works for me.  Something tells me that this might just work for others with the same problem, too.


Go ahead and plug in the camera and turn it on.  Open Device Manager.  Under the View Menu, check "Show Hidden Devices".  Scroll down to the bottom of the list, expanding categories as needed, and find "Canon Digital Camera".  There may be more than one copy present.


Double click on each "Canon Digital Camera" in the list, click on the Driver tab, click Uninstall, and CHECK THE BOX that says "Delete the driver software for this device."  Then click OK.


Do this for each entry labeled "Canon Digital Camera."


Then, with your camera still plugged in and turned on, click the Action menu and choose "Scan for hardware changes".


During the subsequent driver installation, hopefully, you will see the camera being installed as Canon EOS 70D (or whatever model you have) instead of the generic "Canon Digital Camera".


After installation completes, open EOS Utility and you should be good to go.


I hope this helps somebody out there. 🙂




Registered here just to say thank you!


Solution you've described is 100% works for me. You're a life and time saver!

Alexis83:  Woo hoo! Glad that helps!

Dear Blake (a/k/a SloMoHolic),


    Thanks very much for your feedback.  I was struggling with this issue for about an hour and a half today, and your suggestion was about 50% responsible for my resolution.  I had to read through 9 pages of the forum before realizing the final solution, which was a combination of changes.


    First and foremost, good job on finding the "Show Hidden Devices" in Device Manager.  I've been an IT consultant for 10 years, and I've had to do this many times to help clients, but I sort of forgot about that option until I read your post.  I had 3 separate and seemingly identical entries (for some reason) for my camera.  I deleted all of them, then selected Scan for Hardware Changes.  My system churned for several minutes (which is unusual, considering I have a 256 GB SSD and 8 GB RAM, with a 4th gen i7 processor), and after that I could at least see the camera again in My Computer.


   I read another user who mentioned possible conflicting Windows Updates.  So, since my EOS utility was still not working, I uninstalled the most recent Windows Update (I should have documented which update it was, ... I think it may have been KB2995387, but I'm not entirely sure), rebooted, and voila!  My EOS Utility was back to being functional.


    Just to reiterate for any other users who post silly things like "just use a card reader", I'll have you know that I have a card reader, and yes, it is 5x faster than using my USB cable, but the reason I like the EOS utility is that it places my photos in dated sub-folders automatically.  This is an incredibly useful feature.  It's also worth mentioning that I am using Windows 8 x64, and I previously had Windows 7 x64.  Since the Canon web site does not have the option to download the original disk, I had to copy the program files from my old PC to the new PC (a few months ago), and I was very happy that this unorthodox approach worked.


Best of luck to all of you who suffer through this issue of the EOS Utility not functioning,


Following my ealrier moans about Canon Utility problems with WIndows 7 and a new 70D, I have resolved half the probblem which was of my own making - I still had WI-FI enabled which prevents the computer seeing the camera.  May I suggest to CANON this fact is put in BOLD RED in the handbook!!


I still have a probelm with the latest version of Utility in that it no longer gives you download and file options but, instead, as soon as the camera is switched on, automatically starts downloadong from the camera to the last file you accessed.


Does anyone have a fix for this??


Thansk in advance.



Hi descendeur10 (Kerrin),


Plug in the camera and open the EOS Utility (and cancel the image download if necessary).  From the main EOS Utility panel, click the Preferences button at the bottom.  In the Basic Settings tab, change the Startup Action from "Execute [Starts to download images]" to "Show [Lets you select and download images] screen" or one of the other "Show" options.


I hope that solves it for you. 🙂



Thanks for the suggestion Blake:  Have just tried and it and this time it worked.  I had previously tried the same approach with my old 550EOS and could not get the selected "Show" choice to stick.


I'll keep my fuingers crossed but not hold my breath.


Thanks again




Thanks Blake, after trawling through dozens of "solutions" yours seems to work and I can now offload my photos. Thank you so much!



click here to view the gallery