cancel
Showing results for 
Search instead for 
Did you mean: 

EOS utility not working

EOSU3IsAnnoying
Apprentice

For whatever reason after a few days of not using EOS utility the software will not recognize my camera even if windows 10 does, I have turned off WiFi/NFC and connected it via usb but EOS utility does nothing with it. When I use EOS Utility 3 it just says "Connect an EOS camera." despite it already being connected. When I have used EOS utility 2 the software says "Camera is not recognized" when I launch the software and then connect the camera it immediately closes and gives that message as well.

 

Solutions Tried:

Double checking WiFi/NFC is disabled

Deleting the driver on windows and re-installing it (x10+)

Deleteing and re-installing EOS Utility 2 and 3 (x2)

Contacting support (they didn't seem to read my message and recomended me a solution I had already tried)

Giving up on life

 

Specs:

EOS Rebel T6

Windows 10 Home

 

I just don't know what else to do

Dang_(

26 REPLIES 26

Waddizzle
Legend

Try a different cable.

--------------------------------------------------------
"The right mouse button is your friend."


@Waddizzlewrote:

Try a different cable.


+1 what wadizzle said... 

 

Other possibilities:

-Plug USB directly into port on machine, not into a hub (if you are using one)

-Are you using a 3rd party AV?  If so, try disabling.  

 

If you are using Windows Defender for AV, thats not a problem.  

~Rick
Bay Area - CA
~R5C (1.0.1.1) ~Many Lenses ~DxO PhotoLab Elite ~Windows10 Pro ~EVGA RTX 3080Ti FTW3 Ultra
~ImageClass MF644Cdw ~Pixel6 
~6D2 (v1.1.1) retiring

It did not work

soundscaping
Apprentice

Remove the WiFi card from the camera then plug in and turn it on! If the Eos Utility doesn't come up, manually start it and it should recognize the camera.

 

This worked for my 7D MKII on both Windows 10 (Eos Utility 2 and 3) and my Macbook Pro 15" mid 2015 Sierra OS!!!

 

Hopefully this will work for many who experienced non detection and hours of online research and troubleshooting!!

 

:]

I have the same problem and it's extremely frustrating. Used to work fine.  Uninstalled and reinstalled twice

 

It has nothing do with USB cables (2 cameras, two different ports, 2 different cables) and Windows beeps as it should when powering up and down.

 

It also has nothing do with WiFi as my PC doesn't have WiFI nor have I ever connected to either camera using WiFi. I think it just has that WiFi drodown because nothing else is working and it's grasping for options.

 

My guess is it has something to do with DropBox or OneDrive or Google Photos or someone else  grabbing the camera and not letting go.


@royanderson wrote:

I have the same problem and it's extremely frustrating. Used to work fine.  Uninstalled and reinstalled twice

 

It has nothing do with USB cables (2 cameras, two different ports, 2 different cables) and Windows beeps as it should when powering up and down.

 

It also has nothing do with WiFi as my PC doesn't have WiFI nor have I ever connected to either camera using WiFi. I think it just has that WiFi drodown because nothing else is working and it's grasping for options.

 

My guess is it has something to do with DropBox or OneDrive or Google Photos or someone else  grabbing the camera and not letting go.


Are you running a native installation Windows 10, or a Windows 7/8 upgrade to Win10?  

Sometimes you have to manually start the EOS Utility the first time you try to use USB.  For some reason, the EOS Utility seems to want to default to a LAN connection, which means it is not looking at the USB ports.  

 

There is an “EOS Lauancher” Utility that decides whether to launch the LAN Utility or the USB Utility.  The screenshot in the first posts shows the LAN Utility, but it also shows a message from a bad USB port/cable.

--------------------------------------------------------
"The right mouse button is your friend."

I'm running the most recent version of Windows 10. The only way I can get the utility to start at all is to do it manually, at which point I get the screen with the "Connect an EOS camera." message. At this point both cameras, 6D Mark II and M50, show the connection icon on the menu screen.

 

Except for some transisition problems from V2 to V3 for my older 40D, I've been running the utility software for 10 years without any problems. Although becaise of all the devices I have it's been a long time since the utility woud autolaunch, but I've always been able to get it to work manually.


@royanderson wrote:

 


”I'm running the most recent version of Windows 10.”

 

“I've been running the utility software for 10 years without any problems.”


That is not exactly what I asked about your Windows 10 installation.  Your reply is irrelevant because Windows 10 will eventually update itself, irregardless of whether you want it to do so, or not.

 

Your complaints about the EOS Utility are consistent with complaints from people who are running Windows 10 on the older Windows XP/7/8 compatible hardware.  Windows 10 introduced security driven changes in computer hardware. 

Your second comments would seem to confirm my initial suspicion that you are using older hardware, which may not be fully compatible with Windows 10.  PCs that were built for Windows 10 interact with the computer hardware very differently from older machines.  People running older Acers, or PCs with non-Intel CPUs, are out of luck, and need to upgrade their PCs.

You may try launching the EOS Utility without a camera attached, and right clicking the icon on the Taskbar and selecting startup options.

--------------------------------------------------------
"The right mouse button is your friend."
Announcements
09/19/2022: New firmware version 1.0.4.1 is available for EOS C70
08/31/2022: New firmware version 1.1.1 is available forRF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/28/2022: New firmware version 1.2.1 is available for EOS-R3
07/21/2022: New firmware version 1.6.0 is available for EOS-R5
07/21/2022: New firmware version 1.6.0 is available for EOS-R6
07/21/2022: New firmware version 1.1.0 is available for EOS-R7
07/21/2022: New firmware version 1.1.0 is available for EOS-R10
07/14/2022: New firmware version 1.0.1 is available for CR-X300
07/01/2022: New firmware version 1.3.0 is available for PowerShot PICK
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!