Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS utility 3 and Apple Silicon CPU (big sur OS) (EOS Utility 3.13.20 for macOS)


There is no information on this anywhere with Canon. What is the status of the Canon Utility for Apple computers with the ARM M! (silicon) processor: these computers can only run Big Sur (OS11).


Is the Canon EOS Utility 3 (EOS Utility 3.13.20 for macOS) compatible with Apple Silicon computers?



There will be two issues at play with this.


First, I'm almost positive that the Canon utility is still only being built as an Intel binary and not a Universal binary.  However, Big Sur includes Apple's Rosetta2 technology which will still run Intel-based software.  The vast majority of existing Intel software should run in this environment, but alas it's not a guarantee.


Beyond that, you have the OS itself (Big Sur in this case).  I don't use that utility myself, so no idea how it fares on Big Sur Intel-based Macs.


If I remember later, I'll try testing this utility on my Mac (and then inspect its binary to see if my assumption above is valid; i.e. it being Intel-only).


EOS 5D IV, EF 50mm f/1.2L, EF 135mm f/2L, 600EX-RT (x6), ST-E3-RT
EOS C70, RF 24-70 f/2.8L IS, EF-EOS R 0.71x

usually with the rosetta 2 and uninversal binary, it is for apps, not system level drivers. now if the utilty is in fact just an app the needs to be launched and does not load at the system level like an extension, it might work... drivers and audio apps are the big issues with big sur on apple silicon cos the hardware is not "as expected" compared to intel. i have not tried it on my m1 mini as i still have a macbook pro intel to use, i am reluctant to try it less i cause a conflict with my more esental apps before it is officially supported by canon.. canon so far has not issued any sort of statement... apple has begun to discontinue intel models and a new imac pro m1 and macbook pro 16 m1 could come out in late june.


bump for a reply... anyone using a m1 mac?


there appears to be no info from canon if there is native support or if the current OS 11, big sur, version is compatible with rosetta 2 and thus the M1 macs.



I am usng Mac Air M1 here. The Utility works ok for me 90% of the time. (sometimes it cannot automatially recognize the camera after the camera connects to the wifi)


Btw, do you encounter this problem on M1?

i have not tried that yet, nor have i installed it on my M1 mac as since it is a auto launch utiltiy i want to make sure it is compatiable.. as far as the 90% rate, that is about the same i get on an intel mac with os 10.15 catalina, sometimes i have to reconnect the camera to the usb.

It seems I’m not alone. Have tried to install EOS utility and DPP on my MBP M1. Have unzipped and executed the dmg file but the Installation execution aborts prematurely. Have tried many versions but nothing work.

it might have an OS version flag or it does not have persmission due to changes in that structure.... also some extension require a reboot sequence and hardware security unlock...

@tntula wrote:

it might have an OS version flag or it does not have persmission due to changes in that structure.... also some extension require a reboot sequence and hardware security unlock...

The Apple M1 is an entirely new hardware/software platform from the ground up.  

"The right mouse button is your friend."

I've recently upgraded to Big Sur, and just today tried to use the both the Image Capture, with USB, as well as the Utility software. My iMac is 15,1,with an Intel i7 core. This is NOT apple silicone. However Image Capture after the upgrade to Big Sur 1) does not recognize the M50. The old version of Utility suggested I download the newer version, which I did. Did find that it wasn't appropriate for my iMac with Big Sur (again not Apple silicone).  Downloaded both the Catalina versions and the Big Sur version M3.13.20.4. None of the Canon installers worked - they all crashed, all 4 of them. Interesting to note, when accessing the M50 support page, and checking the Operating System tab, it defaults to "Catalina (Detected)" and not the "Big Sur" that is in fact installed. I'm wondering if there's an issue with the Canon side detecting apple software?


No idea what's going on with Image Capture. Meanwhile I'll see what Google says about the installer issue, and maybe head to Apple as well. 


Any suggestions (other than removing card and using a card reader) for getting the Utility to work on my M50-iMac (15,1) would be appreciated. Thanks

Enter for a chance to win