cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS Webcam not connecting. EOS 90D, Mac OS 10.15.7, Wi-Fi OFF on camera.

Mooseboy08
Apprentice

Hey all, here's what I'm seeing:

 

Screen Shot 2020-12-30 at 4.45.28 PM.png

 

I've tried different cables, different USB ports. Camera is on movie mode, tried several different frame rates, nothing.

 

Applications that I've tried are: QuickTime Player, ImageCapture, Zoom (both the application and through Chrome browser). Basically everything that I've tried gives me the above error screen.

 

I believe that the camera "sees" the computer, because when I try to look at a menu, the camera tells me "busy".

Rebooted the computer several times. Spent an hour with Canon telephone support with a very patient person, but no luck.

 

Any other ideas that I haven't already tried? tia.

3 REPLIES 3

Waddizzle
Legend
Legend

Is the camera's Wi-Fi and Bluetooth disabled?  If you were on the phone with Canon Support, I would assume that they checked that you had the camera set for USB communications.

 

I know that there are some issues with latest MacOS.  There can also be issues with how you complete the USB connection between the camera and the Mac: i.e.; port expanders frequently seem to have problems with Canon cameras.

 

I am not sure what the Red"X" means, but it seems to mean that there is no camera device attached.  Can you make the regular EOS Utlity work properly to download files, and remote shooting?

 

Also, there are a couple of apps that run on the Mac that seem to block the Webcam Utility from accessing the camera.

--------------------------------------------------------
"The right mouse button is your friend."

Waddizzle, thanks for the reply.

 

You're right, we did check both Wi-Fi and Bluetooth, I should have mentioned that. I haven't tried the other EOS utility apps, so I'll give those a go.

 

Thanks for the suggestion!

Well, I tried EOS Utility and no go. It must be something in my OS or a plugin that I have that keeps the computer from seeing the camera, even though the camera sees the computer.

Avatar
click here to view the gallery
Announcements