cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS Utility won't recognize EOS 1100D

newcamerauser
Apprentice

Hi there, 

I have an old Canon 1100D - and I cannot get EOS Utlity to recognise the camera. I have MacOS Catalina. 

 

Is there any way to make this work? - I have downloaded version 3 and version 2 and neither of them are working. I really need to use this for the remote camera function! 

 

 

Thanks everyone!  

 

 

2 REPLIES 2

kvbarkley
VIP
VIP

I imagine you are out of luck. The older version were probably 32 bit which won't work on Catalina, and the newer version won't support your camera.

 

If upgraded your computer to Catalina, you could possibly go back to  Mojave, but it is a messy process. You might also be able to boot your computer from an external drive with an older version of the OS.

jrhoffman75
Legend
Legend

Are you saying EOS Utility 2 isn't executing on your computer?

 

Is your camera detected by Image capture?

 

On my Catalina machine EOS Utility 2.14.31 runs fine. It can be downloaded from the Mojave OS site for your camera. The date for the software is 2018.

 

See this note assocuiated with EOSU3 download for latest 1D X Mark III:

 

Annotation 2020-05-07 163147.jpg

 

Do you have the latest version of Catalina? There was a tethering issue that has been fixed in latest update.

John Hoffman
Conway, NH

1D X Mark III, M200, Many lenses, Pixma PRO-100, Pixma TR8620a, Lr Classic
Avatar
click here to view the gallery
Announcements