cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS Utility macOS Update

kikim6600
Apprentice

Does anyone know when the EOS Utility will be updated for Mac OS 13? I'm opening it but it won't connect to my camera.

9 REPLIES 9

Tiffany
Moderator
Moderator

Welcome to the Canon forum!

So that the Community can help you better, we will need to know what model Canon equipment you are using. Any other details you'd like to give will only help the Community better understand your issue.  If this is a time-sensitive matter, click HERE search our knowledge base or find additional support options HERE

Thank you!

I’m using an EOS product… trying to connect my camera (I don’t think it really matters what camera, as long as it’s EOS) 

The same thing has happened with various Canon cameras. Please see my other reply in this thread for detail.

---
https://www.rsok.com/~jrm/

jrhoffman75
Legend

If you are using EOSU to download images from camera you can use Image Capture instead. 

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic

johnrmoyer
Rising Star

This was a major failure of Apple software engineering test and release procedures. (The last time I introduced such a serious bug into released software was 1985.) I use EOS Utility 3 to update date/time and IPTC info on my camera and I am unhappy about this loss of functionality.

After upgrade to macOS 13 Ventura, both Android File Transfer and EOS Utility 3 stopped working on my iMac. The USB ports were set to power only and no data during the update.

Someone at Apple support suggested that I reset NVRAM on my iMac and that restored data functionality of the USB ports. After that, Android File Transfer works and the Apple Image Capture App can talk to my EOS R5 over the USB C cable that came with the camera. EOS Utility 3 still does not work. This demonstrates that the USB firmware in the camera is fine, but EOS Utility 3 still has a problem. If resetting the NVRAM is necessary, that should have been noted by Apple software engineering and put into the release notes or better yet put into the software that did the update.

I have not yet tried deleting and reinstalling EOS Utility 3, so it is possible that might work.

Procedure to reset NVRAM: https://support.apple.com/en-us/HT204063

Procedure to reset SMC on mac: https://support.apple.com/en-us/HT201295

This is my best guess for the origin of the bug:
https://developer.apple.com/documentation/macos-release-notes/macos-13-release-notes
"

Accessory Security

New Features

  • On portable Mac computers with Apple silicon, new USB and Thunderbolt accessories require user approval before the accessory can communicate with macOS for connections wired directly to the USB-C port. This doesn’t apply to power adapters, standalone displays, or connections to an approved hub. Devices can still charge if you choose Don’t Allow.

    You can change the security configuration in System Settings > Security and Privacy > Security. The initial configuration is Ask for new accessories. Configuring an accessibility Switch Control sets the policy to always allow accessory use. Approved devices can connect to a locked Mac for up to three days.

    Accessories attached during software update from prior versions of macOS are allowed automatically. New accessories attached prior to rebooting the Mac might enumerate and function, but won’t be remembered until connected to an unlocked Mac and explicitly approved. (43338666)

"

While my iMac has an Intel CPU and not an Apple CPU, I speculate that Apple software engineering failed to perform adequate testing on machines with the Intel CPU before releasing the update.

---
https://www.rsok.com/~jrm/

Tried changing the security parameter (the camera was detected, as MacOS asked if I wanted to allow it to be connected), uninstalled ans reinstalled, but no luck.

Very annoying because I can't check and clean my memory cards on my normal computer being away.

johnrmoyer
Rising Star

After resetting NVRAM on my iMac, deleting EOS Utility3, downloading and installing EOS Utility 3 for macOS 11, now it works again. I hope this might be helpful for someone else.

---
https://www.rsok.com/~jrm/

John, (Cheers!)

Helpful.  I'm sure this will make some people's day here.

I also noted your reference about to the newly implemented thunderbolt security features requiring approval.  This was implemented in Windows eons ago.  I wonder if these permissions can be modified in Security Preferences without uninstall/reinstall of the EOS Utility?

If the entry is missing, users may also be able to browse to it, add then check to enable.

Hopefully one of the other users with this issue will test and report back. (I left my Mac is at the office)

~Rick
Bay Area - CA


~R5 C (1.0.2.1) ~RF Trinity, ~RF 100~400, +Canon Control Ring

~6D2 (v1.1.1) Retiring ~EF Trinity, others ~DxO PhotoLab Elite ~Windows10/11 Pro ~EVGA RTX 3080Ti FTW3 Ultra ~ImageClass MF644Cdw ~Pixel6 ~CarePaks Are Worth It

J03Budd1
Apprentice

I am using a MacBook Pro (Intel) I uninstalled and re-installed Canon Utility 3 and it worked.  I am now shooting tethered again on OS13 Ventura with Canon Utility.

Announcements
01/18/2023: New firmware version 1.1.1 is available for EOS R6 Mark II
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version 1.0.5.1 is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5
12/07/2022: New firmware version 1.7.0 is available for EOS R6
11/22/2022: New firmware available for EOS R3, EOS R7 and EOS R10
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/14/2022: New firmware version 1.0.1 is available for CR-X300
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.