Showing results for 
Show  only  | Search instead for 
Did you mean: 

Digital Photo professional 4 not repsonding


I had lately constant freezing of the "Digital Photo Professional 4" running on Windows 10. This would occur after a "Convert and Save" opretation. The windows app goes grey with the message "not responding" in the window title bar.


Having myself software development experience, I used one of Microsoft monitoring tools called "Process Explorer" to monitor the application activity. I noticed multiple attempts to connect to network drives that were in disconected status (see snapshot at the end) - I had many of these drives.


Disconnecting all the network mapped drives solved the issue. It seems that there is some kind of bug invloved when network drives are not connected. I hope that Canon developers check this out.



Windows 10 Pro - 64 bit

running on intel core i7-2600 - 8GB mem






Product Expert
Product Expert

Hi michelphoto,


Thanks for sharing your observations about DPP. We appreciate that!


We can pass this along to our developers, but before we do that I'd like to get some additional details:

  • Are you able to replicate the issue after restarting your computer?
  • If you have hundreds of images in the folder where you are trying to do the CONVERT AND SAVE option, does it make a difference if you move a few images to a different folder?
  • Does the issue come up even when converting just one image?


We look forward to your reply.

Hi Nick,


Thank you for taking the time to look into this.


Here are the answers to your questions:


  • Yes, this would happen even after a restart of the computer. 
  • I did multiple tests saving to multiple folders. Some with a lot of pictures and others with few pictures. There is no difference. The DDP4 would still hang if there were mapped network drives (in disconnected state). After removing the mapped network drives. I did a test saving (CONVERT AND SAVE) to a folder with  more than 1000 images, it worked well.
  • I had the issue even when converting a single image.

I'm at your disposition for further tests or questions.


Kind Regards,





Thank you for following up with those details, Michel.


I'll go ahead and pass along your feedback and this thread link to our developers for further investigation. If you discover any new quirks feel free to respond to this thread, and our developers should also see the updated notes.


Thanks again fro sharing this with us!

Just a quick update.


I've added again two network mapped disks. I then put these in disconnected state one by one, and tested with  DPP4 "CONVERT AND SAVE" using one image.


With one disconnected mapped network drive, DPP4 worked well but I could notice a slight delay during which if a clicked anywhere on DPP4 window the "not responding message" would appear in the title bar and then disapear.


With two disconnected mapped network drives (see attached snapshot), the delay is more evident, the "not repondig message" appears more frequently. In some cases (~1 out 4 saves) DPP4 is not responsive, and I need to restart it.


Note, at the time of my initial message I had 5 mapped network drives in disconnected state. I suspect the more you have of these, the more DPP4 becomes unreponsive in the case of a "CONVERT AND SAVE".


I hope the above helps Canon Development Team to reproduce the issue.








Snapshot of two mapped network drive in disconnected state.









click here to view the gallery