Showing results for 
Show  only  | Search instead for 
Did you mean: 

Digital Photo Professional 4 Non-responsive Following File Save


I've been using DPP4 since its introduction on my Windows 7 desktop without incident. I just upgraded to a new computer with Windows 10, more RAM (16 GB), and faster CPU (i7-8700). I now find that DPP (4.7) hangs for about 30 seconds following a file save.The strange thing is that DPP (and only DPP) becomes temporarily non-responsive following ANY file save, even a small Notepad text file. Watching Windows Task Manager, I see that the CPU utilization jumps to about 12% following a file save for about 30 seconds, but only when DPP is open. Any idea what's causing this and how to fix it?




So far it seems to be working. I wonder if this can be used to debug what the issue is. Corrupted profile?


Addendum - Amazingly, everything is suddenly faster in DPP with this hack. Changing gamma used to take 15-20 seconds, now it's instantaneous!

Yeah, it could be somekind of corruption. but as new user profile doesnt bug(yet). I'm start to look easy way to duplicate userprofile without losing too much stuff. Until then, Im swapping to different user or starting software as another user if I need to edit pics.

All my photos for editing are on a second drive.  Do you think there is any way I could use your workaround in my case ?

That's the ideal situation. The secondary user needs write access to the files.

Came on here following suffering the same issue which was driving me nuts.


Thanks for the suggestion of the solution


I've found a similar but much easier workaround which is to simply right-click on the DPP4 Shortcut and select 'run as Administrator' more slow downs / hangs


The fundamental issue seems to be with the permissions being assigned to a user are 'Special' and not 'Full Control'


I've yet to tinker with these Smiley Frustrated



Replacing my photo HDD with an SSD made a great deal of difference.  MUCH better.

Thank you so much for that!  My saves were taking 25 seconds. Logging in as a secondary user made it instantaneous. I am only editing JPG files, not RAW. I was not looking forward to learning new software.


you have to check off the ram using, then you will be shocked more. My computer is i9700+32 DDR4+SAMSUNG 980PROX2 on RAID0+1080GTX+Toshiba 4T HDD. , after the files had been saved and the program killed 1.2GB RAM.


Hi All,


This has been bugging me too of late, ever since I brought the 90D a few weeks ago and upgraded my version of DPP, this solution obviously might not work for all but it certainly sorted out my latency save issue amongst a few other slight performance issues on Windows 10!


The Culprit and Solution for me was that I have a second Computer on my network that I only turn on when I need to, (say for backup purposes) and I never disconnect the two attached drives from within Windows Explorer on my Master Computer, I always have these drives showing albeit they are "disconected", and obviously get a warning that Windows "Could Not Reconnect All Network Drives" everytime I reboot/login if the said Computer is not turned on. Once I actually Disconnected these drives from within Explorer my Issue with DPP4's latency dissapeared, therefore my conclusion is that DPP4 is periodically trying to connect to these drives when an action is performed.


Hope this helps someone as I couldn't find any resolution that worked for me and just by chance thought to try this after being bugged for a few weeks!



Thank you Nickerzzzzz - I think this may be my solution as well. I have a NAS device that Windows 10 hasn't been able to connect to since last week and for days I have been having issues with DPP Not Responding. Even talking with Canon and trying additional things including setting up a 2nd profile on my computer we could not ID what the issue was. I knew it was Explorer related, but couldn't figure out quite what. And simply deleting that NAS works. I don't need it on my network as I migrated the files on it to my new NAS, so fingers crossed, problem is forever resolved. 🤗




Yikes, spoke too fast. As soon as I tried to Register settings, thus saving them, the application went back to Not Responding. So I guess I will be running DPP as a different user. So, know I have to figure out how to see, access, and save the files on my primary account when I use the app as a different user.


SMH - this is extremely frustrating.



Figured out how to give permissions to my 2nd user to the folder. Weird way to run DPP, but will see if this works