Showing results for 
Show  only  | Search instead for 
Did you mean: 

DPP 4.9.20 on macOS 10.13




I can't start DPP 4.9.20 on my Macbook Pro 15 mid2015, macOS 10.13 with latest updates. It gives me the message 'An error ocurred' on display, and 'AEGetDescData of non-desc type 'reco' not a good idea' in system log.


I've tried complete re-install, installation under other admin account, update from 4.8.30 version. Nothing helped.


Can somobody give me an advise, please?


Thank you.



Hello axel-ivc, 


I am sorry this occurred.  When you uninstall the software, are you deleting all of the access files and then emptying the trash?  You mention not being able to start the software.  Would it be a fair assumption that so far you have been able to install it within the operating system it just won't open?   

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Hello, Tim.


Thank you for your answer.


Yes, I'm sure that all files of DPP were wiped from my system on the time of deinstallation. I tried a couple different ways: use Canon uninstaller (that was installed with DPP); move application to the Trash, emptying it, and manually removig all directories related to DPP from filesystem.


By the way, the first installation of DPP was performed on a fresh macOS 10.13 after reinstallation. It refused to start from the beggining. Later, I tried to install 4.8.30 with the same result.


You are right, Tim. DPP installs fine. Just doesn't start 🙂


JFI, EOS Utility 2.14.31b works as expected.


Thank you.

Hello, Tim


Just wondering, maybe you have any news about this problem?


Thank you.

Hello axel-ivc, 


We have not heard any news relating to your specific issue, but there has been a newer version of DPP (4.10) that was recently released. I recommend installing this version of DPP which should work as expected.


Please click HERE to go to a downloader for this version of DPP.


After installing DPP 4.10, are you able to launch the software?


If this is an urgent support need, please CLICK HERE to reach our friendly Technical Support Team.


Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Hello, William


After updating DPP to 4.10 it refuses to run with the same diagnostics. Unfortunately...


Probably, I will try to upgrade macOS to Mojave and see what happens.


Thank you


I have Mac OS 10.14.3 Mojave ocn my MacBookPro from 2015, and have no problems with starting DPP 4.9.20. It works fine!

I don´t know if this in helpful for you to know...but feel free to ask me if there is somhing I can do!


Have a nice day! 

I've been having this issue for years now and haven't be able to run DPP under Mac OS so I just have been booting my Mac into Windows using a boot camp install.


I'm curious.  For those that are able to run DPP on Mac OS without any issues, do you have a "Case Sensitive" formatted hard drive?  I'm curious if the "Case Sensitive" APFS filesystem is causing an issue.  It's the only thing I can think of now.


I really wish I was able to resolve this issue.  I originally reached out do Canon for assistance but they really were of no help and didn't seem motivated to help me resolve it.

Now I have macOS 10.14.x and tried different versions of DPP with the same negative result. I also have case sensitive file system.

I might not get around to it for a bit, but I'll try to reformat my Mac sometime soon and I won't use the case sensitive file format.  I'm just curious about this being the issue after recently finding out that Adobe Photoshop fails to install on and does not support case sensitive formatted drives under Mac OS.

National Parks Week Sweepstakes style=

Enter for a chance to win!

April 20th-28th