Showing results for 
Show  only  | Search instead for 
Did you mean: 

DPP 4.18 crashes on editing CR2 from G10


I have been using DPP for nearly 20 years, beginning with an EOS 20D. The latest versions are quite unpredictable but seem to work with all my legacy raw files except those CR2 files from the G10. The program will open those files (haven't tested all the variations) but if the file is opened with the "Edit Image" button or double clicking the thumbnail image. A few clicks (highlight or shadow controls will do it) into editing the entire program crashes. Windows event viewer has two entries, the first says:

Faulting application name: Dpp4Main.exe, version:, time stamp: 0x64104245
Faulting module name: Dpp3Engine.dll, version:, time stamp: 0x64103fba
Exception code: 0xc0000005
Fault offset: 0x000000000016d658
Faulting process id: 0x52fc
Faulting application start time: 0x01d99fa0f0680f43
Faulting application path: C:\Program Files\Canon\Digital Photo Professional 4\Dpp4Main.exe
Faulting module path: C:\Program Files\Canon\Digital Photo Professional 4\Dpp4Lib\Dpp3Engine.dll
Report Id: ec0a3938-bfd0-4ad3-8c39-b159a951c68b
Faulting package full name:

The second says:

Application: Dpp4Main.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: exception code c0000005, exception address 00000270B3F3D658

The OS I use is WIndows 10 Pro 32 Gbytes RAM, 2 Tbyte SSD and 13 Tbyte spinning media in RAID 1.

I have tried removing and reinstalling DPP but the behavior does not change. I will post other anomalies later as time allows. Thanks in advance for any help.


I have used the following Canon camera with DPP, EOS 20D, 7D, 5D mIII, R8, Powershot G10 G5X mII


Product Expert
Product Expert

Hello Grogley,

Your PC specs seem to be more than sufficient. What type of processor do you have? You may want to contact our phone support for further assistance with this. Their phone number is 1-800-652-2666 and they are available Monday - Friday from 9:00 am to 9:00 pm EST.

Thanks for the reply John_Q. My processor is an Intel i9-9900K, so that should be more than adequate for the job. As noted before, DPP works fine with the other RAW files I have going back many years. By joining this forum, I thought this was a way to perhaps provide software MR (at least that is what we called it in the old days). Do I need to do that via the help line (which seems less than ideal to provide crash information and such)? I will try the support number.

Thanks again,



I just got off the phone with the product support line. The tech there was very helpful and was able to reproduce the issue with one of my files using DPP4.18.

Before calling, I tested DPP4.16 running on my Surface notebook with a G10 raw file. It did not crash when editing and did the file conversion without issue. I then upgraded the SW to 4.18 and edited the same file again. This time it crashed pretty much immediately upon editing.

My conversation with the Canon tech, I told him that DPP4.18 works will all my Canon raw files, from the newest R8 and G5XmII CR3 to 5DmIII, 7D and 20D. Only the G10 files crash the program. More specifically, if I am editing in thumbnail mode the program does not crash. As soon as the image is made bigger, then it will crash but with the following caveat. It looks as though that the highlight and shadow sliders are the culprits. I can do pretty much any of the normal edits without crashing but those other sliders will crash the program. Do I remember correctly that originally, those sliders were grey out in DPP for the G10 but not my 20D? Could that be the issue in that the G10 sensor is a CCD but all others that I have used are CMOS?

As I mentioned, the tech uploaded one of my files.and tested and had the same issue. He concluded that my file was corrupt. I disagreed saying that why are just the G10 files corrupt as I have many raw files older, stored the same way from my 20D and they all work fine with DPP. I also told him this same file he tested worked fine with DPP4.16.In addition, the DPP4.18 opens the file just fine, displays it in a larger window without crashing before any edits.

In the end, I was told the issue will be sent to SW engineers for evaluation. I was also told that id DPP4.15 works, use that version. This is not really a good solution since going forward, I will be working with R8 raw files and will want the latest updates as they are available.


I recently upgraded from 13 to 18 and experienced the exact same issue with the exact same types of files.   17 also has the problem so I backed down to 13 which I had been using since it same out.  Was just gettting ready to report problem my self.  Thanks for reporting the issue.  I've been using my G10 since it was first available and am on my 2nd one.  I use it primarily for underwater photography.

I have recently just started experiencing this same issue. I will launch the Canon DPP software and it will get to a certain point and then crash. There is a status bar that appears just before it crashes.  I am using a Windows 10 PC with an Intel i9 processor, 64 gigs of Ram, and a 2 TB SSD hard drive. This recently started when I upgraded to the latest version of DPP. I have a R6II that I purchased Q4 of 2022 and had no issues with the DPP software until I upgraded to the most recent version of DPP.  I deleted dpp4.18.0 and put dpp4.17.10 back on and I am back in the game.  It loaded with no issues.  I can't remember the reason I upgraded (I think it had something to do with the .CR3 files) but the interesting thing is that dpp4.18.0 works fine on my laptop.  I used the same dpp4.18.0 file for both upgrades.