Showing results for 
Show  only  | Search instead for 
Did you mean: 

Connection failed for wifi on r50 camera to phone app


hi im having issues with my EOS R50, im not able to connect to it on my pixel 7 running android 14. bluetooth is fine but when i attempt to connect over wifi to transfer pictures it justs give me connection failed. ive run through all the tips on here to attempt to fix everything short of having to reformat my phone which i feel is a little unnecessary.


ive run on the latest cannon firmware for the camera and the cannon connect app and still unable to wifi connect for any of the features. I've hard wiped any Bluetooth and wifi settings on my phone to see if that would help but to no avail. any help would be greatly appriecated.



So it appears that the issue is fixed with the newest update. In the top right corner menu it has a security section now that allows you to change from wpa3-personal to wpa2-personal and it allows the connection between the phone and camera now. I havnt had a chance to truely dig into how stable the connection is due to work at the moment but thankfully it appears it is now working as it was intended.


Sorry for so much grief I've given those trying to assist and for being annoyed with canon.

View solution in original post


Are you using a Canon R50? Looks like an R5. I don't have those same wifi screens.


Waddizzle and Zander013, 

You are both correct.  I don't believe the steps required for association / connection to the camera which is acting as a hotspot or adhoc network is being performed.  There are no significant differences connectivity wise between the pixel 6, 7 or 8. The 7 is not unique.  

Zander013, can you please post photos similar to mine.

Your camera has the modern Wi-Fi menu.  They work the same however.

Canon Knowledge Base - Connecting the EOS R50 to a Smartphone or Tablet

Troubleshooting steps>

Camera Menu

Turn on Wi-Fi [Enable]

Select phone [Smart Phone]

Connect via Wi-Fi - This tells the camera to start broadcasting its SSID name and password


Open Settings > Internet > Browse for Wi-Fi networks

The camera's Wi-Fi broadcast should appear - If you don't see it, its not broadcasting, recheck your camera.  

Now Select the broadcast, (from list of available networks) just like walking into a friend's house, work or coffeeshop. 

Confirm the phone is connected (Wi-Fi network settings on phone) Do not proceed until this is verified

Bubble acknowledging connection should appear, if it doesn't, open the Canon Connect App yourself.

What do you see here?  The CC app wants to connect to a broadcasting camera in range.

Please try this and report the results.

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Hi I can post pics in the morning when I'm off work. The going direct connect from the wifi works somewhat, it takes awhile to setup and have to setup each time instead of having it connect right away like it should in the app and would be simpler to just plug a usbc into both phone and camera than it is to go through the menu each time to transfer a picture.


I am having the same problem as discussed here. Running the CC app on my pixel 6 pro, it is unable to connect to the Camera's WAP.

Aside from what has already been posted, and the general internet consensus that the CC App needs some work, I'd like to offer that, it would behoove Canon to better explain how the various wireless functionalities should work. It seems like connects the Camera as regular client to my home WLAN. Seems to work.

But the Canon connect app seems to connect via bluetooth (seems to work), but then also via wi-fi, and both 1) through my WLAN like are regular client, but 2) also sort of like in WiFI-Direct mode, but not really, because the camera is acting like a regular WAP (except sans internet access).

It also doesn't help that the Camera (EOS R7)'s menu doesn't clearly show all the settings. While trying to fight this down, I found my way to a screen that has a list of network connections, but it seems like you can only get to it after a connection attempt fails? 

Having had to fight through these type issues on GoPros and DJI drones and the like, it would be useful for some context. Does turning off / disconnecting my house WiFI (i,e: getting the phone and camera off of my network) help? Should I turn off the normally always on VPN on my Pixel? Should I create an VPN exception for the CC app?

I got my R7 a couple of months ago, and it's my first camera with built in wireless, and the functionality is shamefully unstable and less useful than the functionality offered by Eye-Fi cards a decade ago. 



I seem to be one of the few or only person (active here) who is not having issues with Wi-Fi Connectivity on my Pixel devices and 2 body's.  A 6D2 and R5 C.  

shadowsports_0-1709596863331.png - Modern Wi-Fi Menus

shadowsports_1-1709596863334.png - Standard Wi-Fi Menu

Mine is the latter.  

I suspect (but unfortunately) have no way to confirm this has something to do with those body's running firmware that uses the modern Wi-Fi menus.  Note my reply here where I demonstrate connection.

Re: Canon R6m2 and Pixel 7 Pro - won't wifi connec... - Page 2 - Canon Community

I am now using a Pixel 8 with the same result.  Connects 100% of the time.

I do not have a camera with the modern wi-fi menus, so I am unable to confirm the behavior.  I did escalate the issue with as many posts from others I could find.  Still waiting for feedback.    


Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

I don't have access to other camera body's but I have tried with my roommates phone and it auto connects to that when attempting to coinect over wifi as is the expected result.

But I still have yet to have the r50 body connect seamless to the pixel 7 I use as my daily driver. I can do the backdoor ish way of having it connect to it but that's tedious especially when I'm just grabbing a few files to edit on the fly. Most times I can get away with using a USB cable or putting the SD card into my laptop when I'm home but I purchased the body with the expectation to be able to connect over wifi and be able to transport files which is a huge letdown on a otherwise great body.


its a rather annoying problem to have. just the other day i was trying to use a c to c cable and it still kept trying to default to the wifi connection that doesnt work. i really enjoy the camera but i really wish this could be fixed.


I have the exact same issue with the R50 and an ASUS Zenfone 10. It is not a Google Pixel issue, it seems to be anything that runs plain Android (the Asus does for the most part). Canon, can you please look into your software to see how it interfaces with Android?

I'm wondering if it's a variable in wireless module that it's expecting to talk to but it isn't getting the expected response or it's timing out before it gets the reply. I've given up on getting a fix any time soon let alone help here.

I recommend rating the App in the playstore and mention this issue. And I recommend liking posts in this thread. I also have the latest firmware and all - but that firmware is actually just about as old as your post. So there is hope for the next firmware to make everything better. 

click here to view the gallery