Showing results for 
Show  only  | Search instead for 
Did you mean: 

Connection failed for wifi on r50 camera to phone app


hi im having issues with my EOS R50, im not able to connect to it on my pixel 7 running android 14. bluetooth is fine but when i attempt to connect over wifi to transfer pictures it justs give me connection failed. ive run through all the tips on here to attempt to fix everything short of having to reformat my phone which i feel is a little unnecessary.


ive run on the latest cannon firmware for the camera and the cannon connect app and still unable to wifi connect for any of the features. I've hard wiped any Bluetooth and wifi settings on my phone to see if that would help but to no avail. any help would be greatly appriecated.



So it appears that the issue is fixed with the newest update. In the top right corner menu it has a security section now that allows you to change from wpa3-personal to wpa2-personal and it allows the connection between the phone and camera now. I havnt had a chance to truely dig into how stable the connection is due to work at the moment but thankfully it appears it is now working as it was intended.


Sorry for so much grief I've given those trying to assist and for being annoyed with canon.

View solution in original post



I am having the exact same problem. It worked great about two weeks ago and tonight it does not work. I have tried uninstalling and reinstalling the app. Turning the phone off and on. Resetting my camera. Updating the firmware. Removing the Bluetooth and readding. Turned my router off and on. I keep getting the message "Cannot connect to Wi-FI. Please try again later."

Hi just wondering if anyone has resolved this? Thanks

No I have found no resolution to the issue. Canon blames Google, Google says it's up to the app dev to make sure it works the way it should. I've kinda given up hope. If I need to grab a Pic I'll use a type c to c and import or just wait till I'm home

thanks. Looks like I will be returning my £1000 camera. Canon's loss

further info if it helps. It connected perfectly to my wife's Apple phone


Welcome to the forum.

Sorry to hear that you are also having issues with a Google Pixel device.  Over the past month there has been an explosion of new forum members looking for help with the Google Pixel smart devices.  Apparently, there was an update to the smart device OS, and it disabled or otherwise blocked the Canon app, as well as numerous others.  What used to work perfectly, suddenly does not.

Have you checked with Google to see if there are any fixes or updates?

"The right mouse button is your friend."

If I go to Google they are going to be like this is canons problem. I have no issues with my gopro my insta 360 or my dji drone.

How about not kicking us around like a soccer ball and try and provide trouble shooting help and work with us instead of handing us off to someone else.

I was thinking about picking up a cheap tablet until Google and/or Canon gets this fixed. Yes. I am that fond of the Canon App.

I cannot seem to set Wi-Fi parameters on the Camera. It simply utilizes the Phone's Wi-Fi connection. Is this utilizing an ad-hoc (or peer-to-peer) WiFi network?

Would it be advantageous to purchase an external Wi-Fi device for the camera?

U shouldn't have to pickup a new product. Canon should be updating the app to help counter any issues with the app compatibility with phones. Google might have impliment something that broke that functionality but it's canons duty to find away to correct it since going in and fixing it on Google end might break more. If they can't fix the function then put a warning in the app saying there's an issue with the app compatibility with pixels and some functionality might be nonfunctional.

click here to view the gallery