Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon Utility fails to install - macOS Catalina


Hello, my Canon 80D was connecting to my computer nicely until I recently updated to macOS 10.15 Catalina beta. The camera no longer connects properly to my computer, and I am unable to install the EOS Utilities.  The EOS Utility installer starts, asks me for my password, but then freezes at "Preparing to install". 


The advice provided in the High Sierra thread ( has no effect.


Screen Shot 2019-06-27 at 8.35.25 AM.png


Woodle just reported:


"Things have changed somewhat with the release of OS 10.15.3.


EOS Utility 3.11.1 works now under Catalina as under Sierra."


Well - how come? I just upgraded my Catalina to OS 10.15.3 and checked also if EOS Utility 3 now works for me

just fine, so you were wrong, eh?


@newvideo wrote:
Look folks. This is simple.
Apple announced 2 years ago (and reinforced it at the WWDC in 2019!) that the Catelina OS revision would end support for ALL 32-bit software apps.

EVERYONE knew this was coming. 99% of software and utilities vendors were ready at the transition.

Canon’s EOSUtility software was not. The EOSUtility is Canon’s intellectual property. Only THEY have the right to alter it. Period.

Canon has publicly posted that they are working on addressing this situation. This WILL get fixed. No one knows when. That’s just how it is.


As far as I can see, as of today OS 10.15.3 is a DEVELOPER BETA. It’s not an official and approved Apple OS release.

I’d caution anyone who isn’t a legitimate developer to stay away from beta software installs.

That way madness lies.


Not sure I understand the comment of OS 10.15.3 being a Beta version.  I am not a Beta tester so I would have no access to a Beta version.  The OS version that I downloaded was from an Apple automatic software revision.  I assume when it comes by the auto route, it is approved for general use.


In addition, I am confused about the comment about the Utiltiy being a 32-bit version.  If it is truely a 32-bit program, from my experience, it would not respond like it is now responding with the new OS version.  All other 32-bit programs that were on my machine did not load or work under any condition.  

Catalina OS 10.15.3 was available for update 2 days ago.


On my rather new Macs (2017, 2019), EOS Utilities 3 seem to work now as under Sierra, not so for EU 2, which – depending on the age of my Macs – was only working sometimes. Or for the first time at least it needs the "kick" of the Catalina App "Digitale Bilder" to connect with the camera, before iEU 2 opens for selection and download automatically.


Both EU 3 ( and EU 2 ( do not open on my old 2013 MacBook. Strange...


Selection and download of camera files could be done with other Apps, however, the EOS Utilities are very convenient and rather flexible to rename files and directories during download.



Hi Woodley 43!

I have not encountered the problems you indicate...I have a 2015 Mac Book Pro 15" and use the software EOS Utility 3 to download images from my Canon EOS 5D Mk III and a Canon EOS 7D Mk II through the common och cable - 

after download of the new OS Mac 10.15.3 the Canon software EOS 3 works just fine.


Anyway, it is very satisfying to have these contacts with "Canon soulmates" in this community - to be able to discuss various themes with other Canon freaks worldwide!


Have a nice weekend to you all!


Yeah, the old Mac had still OS 10.15.2, it works now under 10.15.3. Still EU 2 (for older cameras), needs a kick, as I described earlier.

Spoke too soon. I got an official update ping 15 minutes ago. Must be rolling out geographically.
Carry on.
click here to view the gallery