Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon Utility fails to install - macOS Catalina


Hello, my Canon 80D was connecting to my computer nicely until I recently updated to macOS 10.15 Catalina beta. The camera no longer connects properly to my computer, and I am unable to install the EOS Utilities.  The EOS Utility installer starts, asks me for my password, but then freezes at "Preparing to install". 


The advice provided in the High Sierra thread ( has no effect.


Screen Shot 2019-06-27 at 8.35.25 AM.png


Att Leeflasche:

Yes, personally I use the image download feature in Adobe Bridge - which works fairly well meanwhile waiting for Apple or Canon to take appropriatec course of action...


Besides, I also always use Bridge an a viewer and it is also the first step in selecting images to work with - a double-click on the thumbnail picture always opens the CR2 raw file in Camera Raw, from there I easily continue my work flow in Photoshop for final adjustmens before saving for the web, printing etc.




To Users of EOS Utility 3.11.1 for Mac OS X and Picture Style File Registration Tool 1.0.0 for Mac OS X

macOS 10.15.2 was released by Apple on December 11, 2019. Following operation checks performed with this version at Canon, we have confirmed a USB connection issue with “EOS Utility 3.11.1 for Mac OS X” and "Picture Style File Registration Tool 1.0.0 for Mac OS X" whereby the functions enabled by connecting a camera and a Mac device via USB cannot be used.

This issue does not occur on macOS 10.15.0/10.15.1. We are currently preparing to release versions of these applications that incorporate a fix for this issue.      

For EOS cameras with Wi-Fi functionality, the camera can be remotely operated from EOS Utility via a Wi-Fi connection with the Mac computer.

For more details, please refer to the respective camera's user manual.

Things have changed somewhat with the release of OS 10.15.3.


EOS Utility 3.11.1 works now under Catalina as under Sierra.


EOS Utility only works after a trick:

When connecting older cameras, such as EOS 5d MarkII, EO 2 does not open automatically. When you start EO 2, the main windoiw appears with no option to select and download images.


However, if I open Catalinas "Digitale" first, and then switch on the camera, EO 2 opens and selection and individual download is now possible!

Great news! I just tested myself, and now EOS utility 3 is back on track again...Perfect!

I asked Canon about this, as under OS 10.15.1 the new EOS Utilities worked fine. Canon was caught by surprise before the end of year changes y Apple: now OS 10.15.2 refused to open EU!
That is by far not the only trap created by Apple Catalina! See community posts...

Yes I know...maybe Apple wants to totally get rid of Canon imaging software...

For the time being, I'll use Adobe Bridge which functions fairly satisfactory!


Yes Adobe Bridge and other Apps may rename imported images. I give every file or directory a place, event and a date when downloading from the camera, so with EOS Utilities it was very convenient to do this. For GPS log data Canon never updated its old processing which visualized GPS registered routes on a map...

It isn't just Canon that are having issues with Catalina. I have a Samsung (HP) Laser Printer that won't print PDF Files since upgrading. AirPrint does no good and all I get are ASCII characters. 


Apple Catalina screwed a lot of things up.

...I fully agree! I used Macs for 25 years at work and privately and never had that many hours wasted as with Catalina...

Look folks. This is simple.
Apple announced 2 years ago (and reinforced it at the WWDC in 2019!) that the Catelina OS revision would end support for ALL 32-bit software apps.

EVERYONE knew this was coming. 99% of software and utilities vendors were ready at the transition.

Canon’s EOSUtility software was not. The EOSUtility is Canon’s intellectual property. Only THEY have the right to alter it. Period.

Canon has publicly posted that they are working on addressing this situation. This WILL get fixed. No one knows when. That’s just how it is.
click here to view the gallery