Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon Utility fails to install - macOS Catalina


Hello, my Canon 80D was connecting to my computer nicely until I recently updated to macOS 10.15 Catalina beta. The camera no longer connects properly to my computer, and I am unable to install the EOS Utilities.  The EOS Utility installer starts, asks me for my password, but then freezes at "Preparing to install". 


The advice provided in the High Sierra thread ( has no effect.


Screen Shot 2019-06-27 at 8.35.25 AM.png


Sorry but in this instance it’s got nothing to do with Apple.


The Canon Utility softwares have not been disabled, they just haven’t been ported to 64-bit by Canon yet.



You can edit previous posts. Click the "Options" tab to the right of your post: the first option is "edit."




Chris P. Bacon
F-1; AE-1; EOS 1V, EOS-1D X Mark III, 5D Mk IV, 6D, 6D Mk II, 7D, and 7D Mk II; scads of Canon, Zeiss, and Sigma lenses.


It is frustrating how some people still try to defend Canon on their slopy technology support. Apple has done what they are supposed to do, evolve their OS to better scale. Or people expect Apple to wait for the slopy software companies to do their work well? Come on!

I saw someone sane in the thread saying that "all his dozens of software on his laptop were upgraded to 64, except Canon". It is Canon's fault! Not Apple!


What shocked me the most here is that Canon is doing nothing! This thread is going on forever and we are still on the limbo. I bought the camera and love it. But I also invested more in lens and accessories because they had support for Mac. If I did not have invested so much on Canon, I would probably now be selling my Canon stuff and buying from the competitor. 


I also saw some folks finding alternatives to download pictures to the laptop. That is easy. It is not a problem. I need the whole set of tools that came with the original product like Utilities, Professional tool to edit my pics, etc. Please, do not offer me Adobe tools, etc. 


Canon, if you are watching this thread, please, so something!

I've had difficulties of late getting Canon software/firmware to download: Apple and Canon point their fingers at each other, and neither are faultless: in recent months, my iPhone, iPad, and MacBook have been anything but stable, and I'm certain the Canon is driven to the point of exasperation trying to cope with Apple's frequent mistakes; on the other hand, I know Android owners that say they've had trouble connecting their cameras to their phone or tablet.  I'm certain that with two different and competing technologies in cellphones, Canon is doing its best to keep up with essentially developing two different sets of software, especially when neither of the two cellphone technologies want to reveal too much to Canon.  However, Canon has lagged behind in getting their software to work with any other technology, especially for as complex as these devices are becoming — and the rapid changes that occur both in hardware, functionality, and software.  (I was given a new iPhone 11 as a birthday present and have already had more than a dozen changes to software in the last few months.  Who can keep up with that?)


To understand Canon, you must attempt to understand Japan and Japanese culture, especially technologically: they are very conservative when it comes to allowing outside influences to affect them, and there is the compelling drive to be superior when it comes to their technology.  Apple changes much too fast, introducing new technology across the board every other year or so — and I'm certain that Apple has cut into camera sales deeply with their iPhones: why would Canon want to develop camera technology in cooperation with a competitor?

Chris P. Bacon
F-1; AE-1; EOS 1V, EOS-1D X Mark III, 5D Mk IV, 6D, 6D Mk II, 7D, and 7D Mk II; scads of Canon, Zeiss, and Sigma lenses.

While I am waiting for Canon to update their software EOS Utility 3 (or for Apple to fix the problem with Mac OS Catalina and EOS Utility), I have discovered that I can download images from any of my Canon cameras using cable and the software Adobe Bridge - which actually is no disadvantage since I am used to (and prefer) work with Bridge/CameraRaw/Photoshop anyway.


It might well be the case that I won't use any Canon software in the future! I recommend you to try this solution if you're having the same problem as I have!



“Itis frustrating how some people still try to defend Canon on their slopy technology support. Apple has done what they are supposed to do, evolve their OS to better scale”

Do know that the Apple latest update broke apps from nearly every vendor? Once again? No one is defending Canon. This is how Apple updates always seem to work out. They tend to break the existing code base in the name of Security.
"The right mouse button is your friend."

Well, I had the same story on my 3 Mac (iMac and 2 MacBook Pro).


When I first installed Catalina 10.15.1, an downloaded Canon Utilies 3.11.1 2020 (EOS2 and EOS3) in October 2019, they worked fine on all 3 Macs.


However, after the (automatic) update to 10.15.2, none of them worked anymore. I contacted Canon and the were frustrated, too. They got surprised just before the end of year hectic and promised rapid repair – but first have to find out the cause of the flop...


I checked today Canon Asia: a "repaired" version of the Canon Utilities is not yet available.


Catalina caused many problems, specially for people who used the Time Machine backups for many years to install their system on new Computers. So 500'000 to 900'000 of files could clubber 70-90 GB of library space (!) and backups do not stop anymore. (see Apple support community)


I'm using OS 10.15.2 (not beta) and the utility does not function correctly.  I get an error message that seems to be related to firewall issues.  This is after I have included the Unitily in the firewall settings.  This happened during the early introduction of the previous OS version.  The highest version at this time for EOS Utility 3 appears to be and it does not function correctly.


It is possible to use the Photoshop "Photo Downloader" with the USB cable to download images without using the EOS Utility.


As this continues to be problem with OS introduction, it would seem reasonable for Canon to be aware early of problems with OS software introduction!!!!