Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon EOS Utility Wifi: No pairing window appears on Mac


I have spent hours on this. I know that Canon's software is pretty poor, but this is really frustrating even after expecting this to be a bad experience.

I have tried connecting my Canon R5 to my Wifi Network and also setting it up as its own Network. R5 is on the latest Firmware, and is the Canon Utility software is up to date. Mac is M3 MacBook Air running Sonoma 14.3.

Canon Utility works with R5 tethered via USB, but I cannot connect EOS Utility to the R5 via Wifi in either wireless configuration (wifi network or closed network). The reason being, the pairing window NEVER APPEARS on my Mac after the pairing (connection) message comes up on the camera. There's no way to force that window to appear in the Mac software, there's no icon in the menu bar...totally dead in the water. I've rebooted the Mac and the camera several times, tried pairing both ways wirelessly at least a dozen times now. Reinstalled the Canon EOS Utility software 3 times.

Can't find help anywhere about this. Everything I've seen either shows the pairing window which mine never gets to or a menu bar icon that does not exist for me.

Any help would be appreciated. Thanks.



I have/had the same issue. I wasn't very happy at all. I found the solution by mistake. I was actually getting ready to uninstall the program and found it. I was researching when I found your post. And it made me want to give up knowing it wasn't just me. So somewhat thanks to you I found the solution. LOL!

Go to the FINDER icon. Click on it. Go to APPLICATIONS on the left. Find canon utilities and expand. Expand the folder that says EOS Utility. NOT eos utility 3. In the EOS Utility folder is "EOS Utility". That is the what you have not appearing and clicking it is how to force it open.

I did have to redo my settings in the cameral a couple of times, which is typical, but it did work. I got it working connected directly to my camera as well as through my home router. I will admit a cable is a lot faster, but at least I got it to work. 

Adam! It worked, you're a lifesaver. Thank you so much. Honestly, I can't believe it...such a goofy thing that it doesn't appear in Launchpad, but is available in the Finder. Weird.

Can you mark the reply as a solution as this helps others find it in the future. 

Thank you 

Brian - Canon specialist trainer, author and photographer
I use British not American English, so my spellings may be a little different to yours