cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon Camera Connect Live View Lag

JaiminRathod
Apprentice

Hello,

I have a M50 MII. I'm using Canon Camera Connect on my phone, Samsung Galaxy S22. The live view feature for taking videos is so laggy that it's unusable! For photos I would just bear with it as I can wait for it to catch up to the camera's movement. But with video it can't work this way.

It's Canon! Such a big company and yet the softwares is not even usable! I had the same issues with an iPad about a year ago.

I've tried both Bluetooth and Wifi connections. I use the camera's WiFi point. The issue remains. I have no case on and my phone is a flagship phone so it can easily handle the software. Please do something about this!!

3 REPLIES 3

Waddizzle
Legend
Legend

First and foremost, this is a user forum.  This is not Canon Service.  If you feel your camera needs repair or an inspection by Canon Service, then I recommend setting up a service ticket with them.

If you require a video monitor, then I recommend using a video monitor, instead of a tablet or smart phone.  The speed of the ability to process real-time video by the software will also depend the number and type of other applications that you running concurrently.

Finally the original EOS M50 does not have a “Clean HDMI” video output.  It was superseded by the M50 Mark II a few years ago, which I believe has been or is about to be discontinued in the near future.

I recommend upgrading your camera to a hybrid model, capable of near high performance video and stills capture.

--------------------------------------------------------
"The right mouse button is your friend."

Thank you for your reply! And also, for pointing out that this is a user forum and not a service center page. I will reach out to Canon for this specific issue.

I do have M50 Mark 2. Getting an external monitor or another camera is way out of my budget and is not a solution to the problem that I mentioned. Other people have also mentioned the same issue but I couldn't find a solution to it online, people with other camera, not specifically M50 M2. I believe that it is a compatibility issue between Canon software and android platform. Though in the past the same problem was also with older version of iOS, I just tested out the app on an iOS device and it is streaming as it is on the camera.

It is quite astounding that Canon isn't addressing this issue.

Update:

I tried connecting the camera in the same way with an old android that I have and it works fine! Thankfully there is a solution for now!

You mentioned the clean HDMI video output which my camera has. Would you know of a way to use a cable to achieve the live view on a phone using that?

Avatar
click here to view the gallery
Announcements