cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Camera connect app not detecting EOS Rebel T6

asglyn
Apprentice

I have my phone connected to the cameras wifi but the cannon connect app is not detecting the camera on the wifi. how do i fix this? Please help

5 REPLIES 5

Tiffany
Moderator
Moderator

Welcome to the Canon forum!

So that the Community can help you better, we will need to know what camera model 
you are using. Which version of Windows or macOS? Any other details you'd like to give will only help the Community better understand your issue.  If this is a time-sensitive matter, click HERE search our knowledge base or find additional support options HERE

Thank you!

its a canon rebel t6. I am connecting to an iphone with version 3.1.20

shadowsports
Legend
Legend

Greetings,

Can you please describe in more detail the steps you are performing and what you are seeing on the phone?

You enable wifi on the camera

it displays the SSID name and password

You open wireless settings on your iPhone

You select the cameras wiifi broadcast and enter its password to connect

The phone connects to the camera

Then you open the canon connect app and what happens?

Do you have a connection registered?

Press the +📷 in the upper left hand corner of the app and enter T6...  select this camera for the list that displays.

~Rick
Bay Area - CA


~R5 C (1.0.7.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Sure thing. 

I enable wifi on the camera

it displays the SSID name and password

I open wireless settings on your iPhone

I  select the cameras wiifi broadcast and enter its password to connect

The phone connects to the camera

I open the cannon connect app and click the plus to register the camera

I type in eos rebel t6 and click the correct model

It brings up the 'wifi-connection' page

At the bottom it says 'Connected Network' and it is connected to the wifi from my camera.

It also says at the bottom "Detects the camera when connected to the same wifi network as the camera'

From here I am stuck. The app does not detect my camera and when I click the X in the top right camera it takes me to the opening app page, directing me to register my camera. When I click the back button in the top left hand corner, it directs me to pick the camera model I want to register. 

It is not detecting my camera on the wifi even when my phone is connected to the wifi from the camera. 

I have used this app in the past and have had no problems but since the update I cannot get them to connect. 

shadowsports
Legend
Legend

Greetings,

If you have a saved camera profile in the CC App, delete it.

Then return to the camera and reset the Network settings.  Not the "whole' camera, just the network.  Then perform the pairing process again.  The steps you are performing are correct.  😀

~Rick
Bay Area - CA


~R5 C (1.0.7.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Avatar
click here to view the gallery
Announcements