Showing results for 
Show  only  | Search instead for 
Did you mean: 

Camera Connect App not working

A month ago I got a new Apple 8 with IOS 12 on it.
I got it Connected to my EOS 70D and had it working.
It was not always connecting easily but it would connect.
Today while trying to download pictures on a holiday it won’t connect.
At first it Connected but only showed about 6 pictures.
When I selected a picture to view and download. After waiting a minute or 2. The picture was still blurry and could not download.
I tried reboot on phone and camera. This time it just showed black squares where the picture should be.
I have now deleted and tried everything but cannot get the App to connect to the camera.
When I go through the App setup I can assign the SSID and the camera shows the connection but stays on that page and never completed the configuration with the phone.
There was a recent update on my iPhone and there is a selection which leads me to believe there was an update to the app.

Thank William!
I know when I was having a problem I did delete the App and reboot the phone.
I thought I had deleted the WiFi settings on the camera as well.
I did delete the App and reboot the phone.
Then I deleted the WiFi settings on the camera and rebooted it.
Installed the App and setup the WiFi connection on the camera.
It Connected as soon as I started the app and all is good!
Thanks again.

View solution in original post



So up until recently, I had no issues connecting my S10 to my EOS Mk50 through the camera connect app. 


Now, during the import of photos from my camera to my phone, it stops at around photo 13, and loses connection, through WIFI. Bluetooth has the same issue. I've tried only selecting one photo. Fails. Tried selecting all - gets to 13 and fails. 


I have uninstalled the app I dont know how many times. I've forgotten both Wifi and bluetooth connections on both devices. It still wont work. I'm getting frustrated as I have over 400 images to import, and when i transfer them from the SD card, to my laptop, and then onto my phone, its decreasing the image quality quite a fair bit, to the point it looks blurred and grainy. 


How can I solve this? 



I've had absolutely no success so far.  I've spent hours on the phone with Canon customer service and they have no answers. They continue to assert that it must be the phone or the camera.  Of course, I've ruled those out by trying differnt phones and other cameras without success.


It's really too bad though.  I didn't buy the camera specifically for that but it sounded like a great tool particulary for remote shutter use, which of course doesn't work either.


I really thought that a company as successful as Canon would have addressed this issue by now.  

I have a T4i and use a USB 3.0 memory card reader for all of my imports. The card reader was super cheap and I've used it a ton, taken it on trips and everything. My camera doesn't connect via wifi so I know I don't understand your frustration, and maybe there is something I am not understanding about the end goal, but I am not familiar with wireless import. 


Maybe this helps with at least getting your pictures to your computer safe and intact?

I am having an issue getting it to connect to my Canon Powershot 620... it worked fine up until today, and I tried two different cameras and two different phones. Any help?


I recently got the Galaxy S20+ and today is the first time I've tried connecting and nothing. I am connected to the camera on wifi, and the back of the camera has the correct SM number for my phone but times out and does not connect. I see where the app updated eight hours ago, but not working.  Nobody has suggested an answer that seems to work. Is anyone from Canon monitoring this board?  I have photos I took today I really want to get over without having to transfer to my  computer and then to my phone.  Thank you.

Hi RickMG,


On certain Samsung devices, we have run into issues with one of the default settings.


In your settings under the Wi-Fi settings, look for the ADVANCED option. Once there, you should see the AUTO NETWORK SWITCH. This is designed to allow the phone to roam seamlessly from available Wi-Fi networks to cellular data, but it does interfere with our Wi-Fi devices. Try disabling this option, and see if that makes a difference.


If problems persist,  I would suggest that you email us at the email below, and be sure to detail what camera you have and what steps you've tried in the email:


Troubleshooting Wi-Fi issues can take be a little more involved in some cases, and email works a little better for that.



Thank you for the info. I have written for more help and hopefully will hear back from Canon. I do not have the AUTO NETWORK SWITCH in my advanced wifi settings but do have Turn on Wi-Fi automatically which is already disabled. I can still connect with my old phone (which doesn't have service (a Galaxy S8+) but not on the Galaxy S20+ 5G, their newer phone. Thank you again.


Rick Green

WIFI connection doesn't work when my 90D is set to "Clean Output" under "HDMI INFO DISPLAY". (I'm using the 90D for live streaming.)  I got Canon Connect working originally, then when I switched to "clean output" it stopped working.


My Solution: Turn off clean HDMI output, use Canon Connect on my iphone to dial in ISO etc needed for the shoot, then close app and switch 90D to clean output.


(Explanation: My 90D is mounted and I can't get behind it without a lot of trouble, so using Canon Connect for setup is a huge benefit. Reconnecting the app with Bluetooth ONLY allows you to click start/stop only, I believe.)


Hope this helps somebody, I wasted a couple hours figuring out that it was the clean HDMI output causing my problem.

Hi Nick!

Can you address my comment from before this last one? I have 2 SX620 HS cameras and 2 iPhones. Neither camera will either iPhone. I have updated the iPhones, I have deleted and reinstalled the app, I have completely disconnected all WiFi networks from the phones, but it still won’t work.

i use canon 70d Eos remote app was working fine in mine i phone but i install this canon camera all set but my phone is connected to camera wifi but the app shows not connected i restart reinstall done every but nothing happen i want to download EOS remote but its already removed
08/18/2023: Canon EOS R5 C training series is released.

07/31/2023: New firmware updates are available.

CR-N700 - Version 1.2.0

CR-N500 - Version 1.3.0

CR-N300 - Version 1.3.0

CR-X300 - Version 1.1.0

06/30/2023: New firmware version is available for EOS-R5 C

05/31/2023: New firmware updates are available.

EOS R6 Mark II - Version 1.1.2

EOS R6 - Version 1.8.2

EOS R7 - Version 1.3.1

05/18/2023: New firmware updates are available.

EOS Rebel T100 - Version 1.1.0

EOS Rebel T7 - Version 1.2.0

EOS 5D Mark IV - Version 1.4.0

EOS 6D Mark II - Version 1.2.0

PowerShot Elph 360HS - Version

PowerShot SX420 IS - Version

PowerShot 620 HS - Version

PowerShot SX720 HS - Version

PowerShot G1X Mark III - Version

PowerShot G7X Mark II - Version

PowerShot G9X Mark II - Version


04/20/2023: New firmware version 1.4.1 is available for EOS R3

03/30/2023: New firmware updates are available.

EOS R5 - Version 1.8.1

EOS 1DX Mark III- Version 1.7.1

Speedlite EL-1 - Version 1.0.2

03/30/2023: Product Advisory for EF50 F1.2 L USM

03/30/2023: Product Advisory for EOS R10

02/24/2023: We've updated Share Your Photos

2/07/2023: New product announcements!

EOS R8 EOS R50RF-S55-210mm F5-7.1 IS STMRF24-50mm F4.5-6.3 IS STMRF15-30mm F4.5-6.3 IS STM
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5