cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

BR-E1 Connection issue

Pauly_6_String
Enthusiast

Hello all. I have a BR-E1 Bluetooth remote that I use with an R6 and a G5X MkII. With each camera I can’t connect the remote consistently.  I often have to delete and re-pair to get it to work with both cameras.

 

Don’t imagine its a compatibility issue (happened on previous remote too before I washed it in my pants). Is there anyone who has had the same issue and resolved it?

5 REPLIES 5

Waddizzle
Legend
Legend

Some Bluetooth devices allow for connections to up to three devices, but not concurrently.  Your two cameras would require separate configurations to be stored in the remote.  Check to see if the User Manual gives you any indication that multiple configurations can be saved in the remote. 

Check with Canon Support to see if the remote is capable of saving multiple connection configurations.

--------------------------------------------------------
"The right mouse button is your friend."

So manual definitely states one camera at a time.  

thanks

FBurr
Contributor

My R6 menu tells me my BR-E1 is 'paired' with the camera, and bluetooth connectivity is enabled. Yet the remote will not fire the camera?

Sailor-retired USN. former 5D Mk II user - recently graduated to the R6

Drive has to be set to remote.

FBurr
Contributor

Ah so! Trying to look this up in the small booklet manual (which in my opinion is worthless) was not helpful. And I didn't have the time to sit at my desktop to page through the more extensive download manual. Hopefully this is one lesson I won't forget! Thank you.

Sailor-retired USN. former 5D Mk II user - recently graduated to the R6
Avatar
click here to view the press release
Announcements