Showing results for 
Show  only  | Search instead for 
Did you mean: 

Vixia HF R800 - shut off screen icons?


I just purchased the Vixia HF r800 to display the artist's work live on a screen during workshops. When the camera is plugged into the TV it shows all of the screen icons. After a little while, it goes into screen saver mode. I am not trying to record, just display what the camera sees on TV. 


Is there a way to shut off the icons? 

Is there a way to keep the camera from falling asleep? 


If this camera is not suitable, what would be? 


Product Expert
Product Expert

Hello smkorby,


Thanks for reaching out!


The camera does have an auto-power down feature that you can find by navigating to the menu and then going into the wrench heading. Try turning that off to see if that helps.


As to the display, there's also the Display Setup heading in the menu, where you can adjust which onscreen displays show up.

You will may see some icons on screen, since the camera is not able to do clean HDMI output. Try tests while recording to see if that helps. You could just use a large memory card and then delete the footage afterwards, if you don't want to save it.


If you're looking for cameras that can do clean HDMI output, you might also look into cameras like

our HF G40, XA30, and XF300.


To learn more about our camcorder lineup, you can visit The ones listed in the pro heading should be able to do clean HDMI.

That camera can have a clean HDMI output.

Agree that the camera can output a clean signal.  I found the setting to do so via 'Other Settings' -> 'Output Onscreen Display', where  the default setting for me was 'yes'.  You just set that to 'no' to eliminate the on-screen icon artifacs from the HDMI signal.

Hello Nick,

I purchased a Vixia HF R800 for the sole purpose of creating training videos, using its Clean HDMI feature.  Canon lists this model as supporting Clean HDMI at the bottom of this page:, but I have not been able to find the setting that removes the Display Icons from the HDMI output.


One of the postings in this thread suggested "Other Settings" and changing the "Output Onscreen Display" to "No," but that option is not listed as a menu option on my Vixia RF R800.  


I would appreciate any pointers you could give to help with this.


Thanks much,


Thanks for following up with us, and I apologize that I was mistaken about the HDMI output of that camcorder.


We aren't able to provide extensive forum support for the Vixia HF R800 though. For additional options, I suggest you contact our phone support line by calling us at (800)652-2666 on M-F from 9am-7pm EST and select the camcorder department from the prompts.

I found that option in this way:

Tap "home" icon

Tap "tools" icon (Other Settings)

Tap second tab at top with the "page" icon

"Output Onscreen Display" is the 2nd option on that page.  Tap it to set it to Off.

Then back out of the menu.


This removed the icons from my streaming output.


Thanks for the tip - it works!


Can it be used to get audio and video live output from HDMI port?  " MyGroundBiz Login "