cancel
Showing results for 
Search instead for 
Did you mean: 

Canon Vixia HF20 - doesn't recognize charger is plugged in

erruggie
Apprentice

Help!

My Vixia HF20 will not recognize that it is plugged in with the wall charger.  I've tried changing batteries (didn't change) and I tested the wall charger to confirm it is putting out the stated DC voltage.  The camera has been in its case and unharmed.  I charged it, shot about 2 hours of video, then plugged it in to charge again and it will not respond.

 

I need ideas on 1 of 2 fronts:

 

1.  Any suggestions on how to get the camcorder to recognize it is plugged in?

2.  What I really am desperate for is a means of transferring the internal memory videos to my computer.  Without the camcorder recognizing that it is plugged in, it will not allow me to use the USB transfer option (USB cable is recognized by camera and computer).  I have also tried the manual's suggestion of using a separate SD memory card to transfer the files onto the SD Card...but it gives me an error because of the mode that the videos were shot in (dual mode).

 

The videos are of my wife with her dying grandfather.  I am desperate for a way to extract the videos so she will always have them.

 

Thank you for your time and advice.

6 REPLIES 6

Nick2020
Product Expert
Product Expert

Hi erruggie,

Thanks for checking in with us.

 

It does seem like something is not quite right with your camcorder at this point. I suggest that you call our support line at (800)652-2666 on M-F from 9am-7pm EST and then select the camcorder department. Our phone technicians can walk you through your service options at this point.

Thank you for your note, Nick2020.  I have tried numerous times to contact your Customer Service line at the number provided.  Because my camcorder is older, the automated system disconnects me everytime.  I then tried your live chat option, and that person also told me to call the same number.  When I explained that I get disconnected everytime, she then told me to post my issue on this forum.

 

It would be great if there was a human being at Canon who might be able to walk me through some basic troubleshooting options.

 

At a loss,

erruggie

Greetings,

Does the CA-570 power the camera with the battery disconnected?

 

If yes, the battery might be faulty, old or at its end of life.

 

If not, you may need to replace the charger.

 

Canon CA-570 Compact AC Power Adapter 8468A002 B&H Photo Video (bhphotovideo.com)

 

Of course there might also be a problem with the camera, but we wouldn't be able to diagnose that for you over the internet. 

 

~Rick
Bay Area - CA
~6D2(v1.1.1) ~Many Lenses ~DxO PhotoLab Elite ~Windows10 Pro ~EVGA RTX 3080Ti FTW3 Ultra ~ImageClass MF644Cdw ~Pixel6 ~R5C On Order

When you say "dual mode", does that mean that when the footage was recorded, you already had the additional SD card installed and it recorded video to both the internal (non-removal) SD as well as the second (removable) SD?

 

If so, remove the second SD card.  Then, flip the write-protect switch.  Since this is crucial footage, you'll want to prevent any accidental writes to that card.

 

If you're using a Mac computer, see if you have an SD card slot on it.  You can then at least transfer the entire contents of that card.   If not, look at obtaining an SD card reader.  Many are very inexpensive.   Be sure to pick up one though that will work with your computer (has the correct cable).

--
Ricky

EOS 5D IV, EF 50mm f/1.2L, EF 135mm f/2L, 600EX-RT (x6), ST-E3-RT
EOS C70, RF 24-70 f/2.8L IS, EF-EOS R 0.71x

Dual mode is a function on the camcorder; it allows for "photos", "video," or "photos and video."  This latter option is what I've had the camera set at for the last 10 years.  Unfortunately, according to the Canon website, having it in this mode apparently changes the format of how the files are saved on the internal memory, and they cannot be copied over to a regular SD card.

 

 

The camera will not recognize that it is plugged in (even if the battery is removed).  SO you think that even though the charger is outputting the correct DC voltage, that it may in fact be faulty?


I'm willing to try replacing it, but since the voltage is correct, I'm struggling as to what will change.  But it is worth a try!

Announcements