cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Unable to get the GPS to work on my Canon GP-E2 with the Canon XF400. GPS light keeps on blinking

umalifam
Contributor

I just bought a Canon GP-E2 so I can geotag my videos because this is the recommended accessory for doing this on my Canon XF400 camcorder. I installed the latest firmware on the GP-E2. When I connected the GP-E2 to the XF400 using the Canon supplied USB cable, I couldn't get the GPS data onto the XF400 even if I have enabled the GPS tracking on the XF400 setup menu. The LED light for the battery and the GPS turns on every now and then and the GPS light blinks 3 times. I tried this outside but I cannot get the GPS coordinates.

I have no other ideas on how to get it to work. I even left the GP-E2 outside for at least 5 mins, but it still could not get the GPS data. Could you please help me get my GPS to work?

2 REPLIES 2

Mark35mmF2
Product Expert
Product Expert

Hi there,

Even if the GPS is not connected to any camera it should be able to find location data, so one thing I would suggest is to take the GPS unit (and camera if you'd like) for a drive to see if there is somewhere else it can better establish a connection. This wouldn't be a guaranteed fix but in case there is some kind of interference near your current location this would remove that variable.

Thanks for your suggestion. I upgraded the firmware. I tried to leave the GP-E2 outside for about 30 minutes but it still can’t get a signal. It is evident that it is defective so I decided to return it.

Avatar
click here to view the press release
Announcements