Showing results for 
Show  only  | Search instead for 
Did you mean: 

Speedlite 600EX II-RT causes camera viewscreen to go black


I have a Speedlite 600EX II-RT that is 20 months old, and a Canon EOS 5D Mark III. I have occassionally had issues with the flash firing at full power regardless of conditions even on automatic settings, but usually the problem resolves if I take the flash off the camera and put it back, so I have assumed the problem was just a loose connection. Yesterday, however, I had a much bigger problem. This time, no matter what I did, the flash continued to fire at full power. Then suddenly my camera's viewscreen went black: I could not see any photos when I pressed the review button, the menu would not appear when I pressed the menu button, nothing would appear no matter what I tried. Finally, after several minutes of experimenting, I was able to restore function by taking the flash off and removing and replacing the camera battery. But as soon as I replaced the flash and took another photo, the screen went dark again. I repeated this sequence three times, confirming that the camera worked fine without the flash, but as soon as I put the flash on, it turned the screen off, never to return until I removed the flash and then removed and replaced the camera battery.


What on earth is going on here? Has anyone else encountered this issue? Is it a faulty flash, or some weird setting I've accidentally triggered?




Be sure that you haven't inadvertently set the flash to TTL (rather than E-TTL). A flash set to TTL will always fire at full poser on an E-TTL camera.

Philadelphia, Pennsylvania USA

Thanks, Bob. My flash is on ETTL. I don't actually even see a TTL setting, but it's possible my settings were causing the full-power firing yesterday -- it doesn't seem to be doing it today.


However, when the flash is turned on, it still makes my camera screen go dark as soon as I press the shutter. I can't figure out how the presence of the flash could be affecting my camera screen.

Hi thelightsall, facing similar issue. Did you get any way out to this yet?

Ruben E Robertson

[links removed per forum guidelines]


I'm having the exact same issue and it's so frustrating. I shoot weddings and during a reception I could no longer preview photos that I had taken. I'm also shooting with the same camera/flashes and I have not been able to resolve this. Luckily I have a 5D Mark ii that allows me to view previews when the flash is on, so I've been using that during receptions. I would like to solve this though. Anyone have any ideas?

Product Expert
Product Expert

Greetings asphotos12,

Sorry to hear that you're experiencing an issue where you're unable to preview the photos when using the EOS 5D Mark III and Speedlite 600EX II-RT. Please check to ensure that the contacts on the flash unit and the hot shoe are clean from debris. You may use a dry microfiber cloth to clean the contacts. Please also check to ensure that the flash is securely locked on to the camera's hot shoe.

If the issue persists then please send the flash unit to our facility for service in case the preview issue does not occur when the camera is not using the Speedlite flash.

Canon U.S.A., Inc. has created a new online repair portal that allows you to set up service in a few simple steps. The repair portal gives you the ability to set up service for multiple pieces of equipment at once, and to receive a repair estimate in the majority of cases, depending on your model and issue. The portal also allows you to upload images or videos that will assist us in repairing your product. You can also select how you wish to be notified of the progress of your repair. The portal's service history section allows you to view all services that have been performed on any of your camera or video products since January 7, 2020.

Please follow the link below to access our online repair portal to arrange for service:

Instructions for Accessing and Using the Online Repair Portal.

You will need to access or create your My Canon Account.

If you already have a My Canon Account and your product is already registered, simply click on the “Get Repair Services” link on the left menu and follow the onscreen instructions to arrange for service for your product.

If you have a My Canon Account and your product is not registered, you must register your product first. Click on the “Get Repair Services” link on the left menu, then click on the “Register Product” link on the right. After your product is registered, click on the “Get Repair Service” link on the left menu and follow the onscreen instructions to arrange for service for your product.

If you do not have a My Canon Account, you will need to create one. After you create your account, click on the “Add Product” link to register your first product. After your product is registered, click on the “Get Repair Service” link on the left menu and follow the onscreen instructions to arrange for service for your product.

Once you have completed the repair request, you will have an opportunity to print a copy of the request for your records. This request form will also contain shipping instructions and an address label that you will attach to the outside of your shipping box when mailing your equipment for repair.