Showing results for 
Search instead for 
Did you mean: 

Speedlite 600EX II-RT causes camera viewscreen to go black


I have a Speedlite 600EX II-RT that is 20 months old, and a Canon EOS 5D Mark III. I have occassionally had issues with the flash firing at full power regardless of conditions even on automatic settings, but usually the problem resolves if I take the flash off the camera and put it back, so I have assumed the problem was just a loose connection. Yesterday, however, I had a much bigger problem. This time, no matter what I did, the flash continued to fire at full power. Then suddenly my camera's viewscreen went black: I could not see any photos when I pressed the review button, the menu would not appear when I pressed the menu button, nothing would appear no matter what I tried. Finally, after several minutes of experimenting, I was able to restore function by taking the flash off and removing and replacing the camera battery. But as soon as I replaced the flash and took another photo, the screen went dark again. I repeated this sequence three times, confirming that the camera worked fine without the flash, but as soon as I put the flash on, it turned the screen off, never to return until I removed the flash and then removed and replaced the camera battery.


What on earth is going on here? Has anyone else encountered this issue? Is it a faulty flash, or some weird setting I've accidentally triggered?




Be sure that you haven't inadvertently set the flash to TTL (rather than E-TTL). A flash set to TTL will always fire at full poser on an E-TTL camera.

Philadelphia, Pennsylvania USA

Thanks, Bob. My flash is on ETTL. I don't actually even see a TTL setting, but it's possible my settings were causing the full-power firing yesterday -- it doesn't seem to be doing it today.


However, when the flash is turned on, it still makes my camera screen go dark as soon as I press the shutter. I can't figure out how the presence of the flash could be affecting my camera screen.

Hi thelightsall, facing similar issue. Did you get any way out to this yet?

Ruben E Robertson

[links removed per forum guidelines]