Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon 600EX II-RT drops link- HELP!


Scenarios I have tried: 


Using Canon Transmitter ST-E3-RT as the master and (2) 600 EX II-RTs as slaves.

Using A 600EX as master and B 600EX as slave.

Using B 600EX as master and A 600EX as slave. 


I get the same result of the slave dropping link. The time varies. Sometimes it drops link in 4 mins, sometimes 10mins, sometimes 20 or more minutes. The only way to relink them is by turning everything off and back on.


All channels are the same. Yes, I have scanned for the best connection as well as every other channel and AUTO.

All IDs are the same. 


Not near a wifi-router or airport, I'm in a row home in Philadelphia. 


Using NiMh rechargeables and using freshly charged batteries for every test. Batteries are about 2 years old. 

I have spoken to 2 Canon service reps and neither of them has any idea what the problem is. I really don't have the money to spend on sending everything in for "repair". 


Any help is greatly appreciated, thanks!





Sadly I couldn't resolve the issue and Canon insisted they couldn't find a problem. I ended up buying new flashes - not an ideal outcome! 

View solution in original post

139 REPLIES 139

A firmware issue with the Godox receiver and transceiver not connecting to the R5 or R6; it appears to have been resolved according to comments. I am waiting for them to arrive to test but here's a link:

No! The problem doesn't resolve. Canon, Where are you?

What flashes worked for you eventually?

This shouldn't be marked "solved."  It might give Canon the wrong idea.

So I have come to the conclusion that it is something inside of my house that is causing interference with the trigger. If I take the setup to a park or my job then they work great will stay linked until the battery dies but but at my house it only last 5 minutes before the connection is lost. I have tried to narrow it down to find out what the culprit is but I cannot. For now I am using Godox X2 trigger and receivers. With the 600 speedlites it works flawlessly but the Godox receiver on the EL-1 speedlite it is a dumb trigger so  You cannot change settings from the transmitter but it will fire if you set them manually. I encourage others to try shooting in a park or secluded location to see if it yields the same results

Interesting… I had tried them outside the house, about 10 yards into the garden, away from all Wi-Fi, but I still had the same issue. Today I took them across the field, around 100 yards away, and the link remained good! It turns out the limit in my case is around 15-20 yards from my house. That’s at about the full range of my Wi-Fi as far as my laptop is concerned.

I’ve been collecting 600EX-RT units for a future project (fortunately I stopped at 3) and tested each as I received them, inside and outside the house, with no obvious problems. I can’t imagine having changed anything significant since the last tests. I also use 3 550EXs with Phottix Laso receivers and they work wonderfully.

I recently added a Canon ST-E3-RT to the constellation, so I now have a total of 7 RT units. This would put my system into the range of the issue reported by p4pictures of 7 or more units, although the error description is rather obscure. However, this may be unrelated if others have the same issue with an EL-1 and a ST-E3_RT Ver. 2, and tseager with only 600EX II units, i.e. no Ver 1 units involved at all.

Yesterday I ordered a Yongnuo YN600EX-RT II flash (cost me the same new as a second hand Canon 600EX) and so far it’s working exactly as expected. I originally wanted to go the Canon route for quality, compatibility and reliability reasons, but that’s not looking to be a very good choice at the moment.

I’d like to bring the units back into the house and systematically turn off all Wi-Fi devices to see if I can identify any offending sources, but that will have to wait until tomorrow as my wife won’t appreciate me interrupting her Zoom meeting!

Thanks for all your responses


After several hours of experimentation I can confirm that the source of interference in my particular constallation were 2 Apple HomePod minis. If I disconnect power to both devices the 600EX-RT slaves remain connected. I've successfully tested for about an hour so far without issue. If I connect power to either HomePod the slaves lose connection within a couple of minutes. Both HomePods behave the same. I have not identified any other problems with any other Wi-Fi devices being affected by these HomePods.

Quite possibly these HomePods are generating more noise than other WiFi devices, and I'm guessing the noise immunity of the Canon flashes is perhaps marginal. The Phottix receivers and the Yongnuo flash do not appear to be affected at all.

While the Yongnuo flashes look virtually identical to the Canon units, you have to look very closely to tell them apart, there are very slight differences in build quality. They even have more features than the Canon units, but I really need them so haven't tested them out yet. Obviously it's early days, but if I were looking for a reliable flash system then I certainly wouldn't eliminate 3rd party products (anymore).

Thanks silverdoggg for your suggestion


I've continued my testing and the results may (or may not 😉 ) be of interest to others.

All Canon units are the first versions.

Firstly, I tested with all 15 channels and a wide range of different IDs but found no difference at all.

Master: ST-E3-RT
Slaves: 3x 600EX-RT
Slaves lose connection, master LED remains GREEN, apparently indicating that the connection loss has not been detected.
Connection can only be restored after recycling power on BOTH master and slaves (as halocastle reported it may be possible to just cycle the RF link but I've not tested this). Sequence is unimportant (slaves before master or master before slaves).

Master: ST-E3-RT
Slaves: 3x 600EX-RT + 1x YONGNUO YN600EX-RT II
Canon slaves lose connection. Yongnuo slave remains connected and continues to flash when triggered by master.
When YN600EX-RT II turned off and on again it fails to reconnect.

Master: ST-E3-RT
Slaves: 3x 600EX-RT + 1x YONGNUO YN600EX-RT II
Master initially turned OFF. All 4 slaves turned ON. Wait ca. 10 minutes.
Turn on master.
Canon slaves do not connect.
Yongnuo slave connects and flashes when triggered by master. 

Master: ST-E3-RT
Slaves: 3x 600EX-RT + 1x YONGNUO YN600EX-RT II
Master turned ON. All 4 slaves turned OFF. Wait ca. 10 minutes.
Turn ON all 4 slaves.
NONE of the slaves connect to the master.

Master: ST-E3-RT
Slaves: 3x 600EX-RT + 1x YONGNUO YN600EX-RT II + 4x Phottix Laso TTL Receivers
All Canon slaves lose the connection to the master. The Yongnuo and Phottix slaves remain connected and trigger when fired by the master.
If I only use 2 of the Phottix devices initially they remain connected as above, but if I turn on the remaining Phottix devices after the Canon slaves have been dropped they cannot connect to the master. 

Previous tests indicate the same behaviour when using a Canon 600EX-RT as a master. This is to be expected because the ST-E3-RT is probably just a simplified version of the flash, and probably uses very similar firmware and electronics for the link functionality.

Slaves: 3x 600EX-RT + 4x Phottix Laso TTL Receivers
All Canon slaves lose the connection to the Yongnuo master.
Phottix slaves remain connected and trigger when fired by the Yongnuo master.
The Canon slaves reconnect to the master after cycling the power to the slaves only, with no further action required on the Yongnuo master.
If I only use 2 of the Phottix devices initially they remain connected as above, if I turn on the remaining Phottix devices after the Canon slaves have been dropped they RECONNECT to the Yongnuo master. 

Same exact scenario for my home. If I take it away to a park they’re totally fine. 5 out of the 20 weddings I had this year produced reception interference inside the church or reception hall. For sure is something per location. The wireless routers???

Every WiFi device both transmits and receives as do the flash master AND slave units. In my case I've identified the source of the interference to be 2 Apple HomePod Minis. If I pull the power on these two the flashes remain connected for as long as I've monitored them.

08/18/2023: Canon EOS R5 C training series is released.

07/31/2023: New firmware updates are available.

CR-N700 - Version 1.2.0

CR-N500 - Version 1.3.0

CR-N300 - Version 1.3.0

CR-X300 - Version 1.1.0

06/30/2023: New firmware version is available for EOS-R5 C

05/31/2023: New firmware updates are available.

EOS R6 Mark II - Version 1.1.2

EOS R6 - Version 1.8.2

EOS R7 - Version 1.3.1

05/18/2023: New firmware updates are available.

EOS Rebel T100 - Version 1.1.0

EOS Rebel T7 - Version 1.2.0

EOS 5D Mark IV - Version 1.4.0

EOS 6D Mark II - Version 1.2.0

PowerShot Elph 360HS - Version

PowerShot SX420 IS - Version

PowerShot 620 HS - Version

PowerShot SX720 HS - Version

PowerShot G1X Mark III - Version

PowerShot G7X Mark II - Version

PowerShot G9X Mark II - Version


04/20/2023: New firmware version 1.4.1 is available for EOS R3

03/30/2023: New firmware updates are available.

EOS R5 - Version 1.8.1

EOS 1DX Mark III- Version 1.7.1

Speedlite EL-1 - Version 1.0.2

03/30/2023: Product Advisory for EF50 F1.2 L USM

03/30/2023: Product Advisory for EOS R10

02/24/2023: We've updated Share Your Photos

2/07/2023: New product announcements!

EOS R8 EOS R50RF-S55-210mm F5-7.1 IS STMRF24-50mm F4.5-6.3 IS STMRF15-30mm F4.5-6.3 IS STM
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5