cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon 600EX II-RT drops link- HELP!

Phillyphoto
Apprentice

Scenarios I have tried: 

 

Using Canon Transmitter ST-E3-RT as the master and (2) 600 EX II-RTs as slaves.

Using A 600EX as master and B 600EX as slave.

Using B 600EX as master and A 600EX as slave. 

 

I get the same result of the slave dropping link. The time varies. Sometimes it drops link in 4 mins, sometimes 10mins, sometimes 20 or more minutes. The only way to relink them is by turning everything off and back on.

 

All channels are the same. Yes, I have scanned for the best connection as well as every other channel and AUTO.

All IDs are the same. 

 

Not near a wifi-router or airport, I'm in a row home in Philadelphia. 

 

Using NiMh rechargeables and using freshly charged batteries for every test. Batteries are about 2 years old. 

I have spoken to 2 Canon service reps and neither of them has any idea what the problem is. I really don't have the money to spend on sending everything in for "repair". 

 

Any help is greatly appreciated, thanks!

 

 

 

1 ACCEPTED SOLUTION

Sadly I couldn't resolve the issue and Canon insisted they couldn't find a problem. I ended up buying new flashes - not an ideal outcome! 

View solution in original post

193 REPLIES 193

7thWheel
Contributor

Quick Question. If I go back to the STE3RT version 1 will I still have the dropping issue or is it only limited to the version 2. 

It's not the transmitter, version 1 or version 2, they do not have the problem in my opinion. It's the flash units that lose the connection, because I made several tests. I know it's not the transmitter, because if you have everything connected between the transmitter and the flash, you have green lights on both. Turn off the transmitter, and you get the red light on the flash, which is to be expected. Turn on the receiver, you get green lights, so you know things are well. However, turn off the transmitter for about 2-5 minutes, leave the flash on, and then when you turn on the transmitter, you will find you lost connection, and the only way to solve it, reboot the flash (power off/on). So if the transmitter was OFF, and when it was turned back on and you lost connection, how can it be the transmitter? That's my thought. 

If you turn off the transmitter (the controller and flashes are actually all transceivers) and wait until the flashes have tripped up, you've effectively just performed a fresh restart of the transmitter. It will most likely work as expected, for a while, unless you're unlucky with the timing. Try leaving the entire system running until the flashes turn red. The controller will still look ok, the led remains green and the status indicators show that all flashes are still connected (although they're not). If I do this, and power cycle just the flashes, in my environment, the flashes will not reconnect unless I also power cycle the controller.

The Phottix Laso adapters and controller do not have this issue. They are fully compatible with the Canon system which indicates that although the issue may be due to some periodic 2.4GHz signals, which I wouldn't necessarily call interference, it does show that the underlying system/protocol is actually fine. Canon have just messed up with the failure recovery / robustness.

If I were to start over I'd buy Godox - but for yet another reason - apart from saving money. Canon only make small "on camera" type flashes. You're out of luck if you want anything more powerful later. I've just added 2 Godox AD400's with a X2T-C controller, that's the older one with the hotshoe. I can then mount a Canon/Phottix controller on the X2T-C hotshoe to get 5 groups on the Godox system plus another 3 groups on the Canon/Phottix (I don't know why all 5 are not available). It's not exactly convenient but it does work.
Note: I only use manual flash mode and I suspect only group A on the Canon controller will work in TTL mode, but I've never tested it.

I have 4 600 RT's with the single EL-1 on my camera controlling them. Some situations it works fine all night.  Except some venues it drops the connection every 5 minutes or so, I have to manually turn off and on each flash to make them turn green again. Doesn't matter if I scan for channels, I've literally tried all 15 channels in a single night, same issues over and over and over.  SOMETIMES I have to power cycle the on-camera flash, but that's random.  SUPER frustrating for professional gear.  It's always in venues that have venue wide wifi.

garmanmd
Contributor

I have also struggled with this problem of losing sync seemingly when newer wifi is present.  I have heard that Phottix Laso can drive canon RT flashes.  Does anyone know if it has been tested and that this solution works in the same settings where the Canon triggers fail?

 

I would like to know also. Thank you!

I talked to B&H and while they still have some Photix triggers in stock, they aren't making them anymore and they are just running stock out, so buy with caution.

First of all, as mentioned by Garmanmd, the Phottix Laso system is no longer produced. I managed to pick up some additional triggers and controller at a significantly reduced price from theflashcentre.com in the uk, but now I can only find the controllers in their webshop.
In my environment all 3 of my 600EX-RT(s) and the ST-E3-RT lock up within at least 8 minutes, guaranteed! The Phottix Laso triggers and their controller DO NOT. I also bought a YONGNUO YN600EX-RT II for comparison purposes and it also runs with zero lockup issues.
I listed my tests (prior to purchasing a Phottix controller) in this post.
I now have 7 Laso triggers and 2 controllers and use them on 3x 600EX-RT and 4x 550EX flashes with absolutely no issues to date.

HOWEVER, as I mentioned in an earlier post, I would personally now recommend using Godox X1R-c triggers on 600EX-RT flashes (unfortunately they do NOT appear to work on my older 550EX units) and either the XPRO II or X2T-C controllers instead. They're not compatible with the Canon RT radio system (which I don't think is a great loss) but the triggers are smaller and less expensive than the Phottix Laso triggers. The Godox range of flashes also extends to studio type heads if you ever need anything more powerful. I recently purchased 2x AD400pro flash heads, so instead of firing 4 strobes into an umbrella, I now fire an AD400 into a large soft box - there's simply no comparison! Canon offers nothing like this at all. So far, the only issue I've had was changing the channel inadvertently when removing the X1R from the flash without turning them off. The channel button is easily pressed, but now I'm aware of it. Otherwise everything has worked perfectly, no hiccups whatsoever. I only wish I'd gone this way earlier, it would have saved a lot of cash and frustration...

when you say the Godox X1R-c are not compatable with Canon RT system, does that mean you are using them in the older optical mode denoted by the lightning bolt?  I have an old school canon ET-S2 transmitter that will also do that, although more limited in its choices and of course brings back all the limitations RT fixed (or at least fixed until recently when they stopped working correctly).  It is a bit astounding that Phottix could figure out to solve this problem in the trigger only, and Canon either cannot or does not want to.  They remain completely silent on this problem, and give no solutions.  I've been a Canon shooter for over 50 years, and find this very disappointing.

"...does that mean you are using them in the older optical mode..."

No, he's using the Godox radio system -- no Canon flashes allowed w/o Godox receiver attached (with transmitter atop the camera).

If having read this ENTIRE thread and still not satisfied:

If you want to keep your Canon speedlites and do non-RT radio, then a pair of YONGNUO YN622C II are a good option as they're transceivers.

If you want to acquire new gear that's RT compatible (trigger, speedlite or strobes), then look to Westcott.

Avatar
click here to view the press release
Announcements