Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon 600EX II-RT drops link- HELP!


Scenarios I have tried: 


Using Canon Transmitter ST-E3-RT as the master and (2) 600 EX II-RTs as slaves.

Using A 600EX as master and B 600EX as slave.

Using B 600EX as master and A 600EX as slave. 


I get the same result of the slave dropping link. The time varies. Sometimes it drops link in 4 mins, sometimes 10mins, sometimes 20 or more minutes. The only way to relink them is by turning everything off and back on.


All channels are the same. Yes, I have scanned for the best connection as well as every other channel and AUTO.

All IDs are the same. 


Not near a wifi-router or airport, I'm in a row home in Philadelphia. 


Using NiMh rechargeables and using freshly charged batteries for every test. Batteries are about 2 years old. 

I have spoken to 2 Canon service reps and neither of them has any idea what the problem is. I really don't have the money to spend on sending everything in for "repair". 


Any help is greatly appreciated, thanks!





Sadly I couldn't resolve the issue and Canon insisted they couldn't find a problem. I ended up buying new flashes - not an ideal outcome! 

View solution in original post

139 REPLIES 139


I actually started this conversation, but somehow I'm now a spectator instead a contributor. 


They are aware of issue. Do they care to find the solution….

I am also having this issue at 2 specific locations, that use home pod wifi and wifi light setups. I have an EL-1 and Four 600 RT's   Disconnect after 2-3 minutes EVERY time.... Hard to be a "professional" when my professional gear doesn't perform.


I am also having this issue at 2 specific locations, that use home pod wifi and wifi light setups. I have an EL-1 and Four 600 RT's   Disconnect after 2-3 minutes EVERY time.... Hard to be a "professional" when my professional gear doesn't perform.

I need to shut down all my HomePods and Apple TV. Then there is no disconnect.

Yes. But what we can do at events? 
Therefore, Chinese flashes that cost 3 times cheaper work, and Canon for $ 1000 loses the connection and does not look for it again in 15 minutes.

I'm really shocked. 

Interesting you mention that shutting down the Apple TVs and Apple HomePods solves the issue for you, but I have done this same test and while I do not own Apple HomePods, I do have the Apple TV, and shutting down the Apple TV does not alleviate the disconnect issue. in my opinion, it's the new WiFi-6 mesh wireless access points causing the issue!

It sounds like a general issue that could be triggered by a variety of devices. I don't have mesh WiFi but I do have 2 HomePods and I can clearly demonstrate that they don't get along with the Canon flash system. This evening I took a ST-E3-RT, a Canon 600EX-RT and one HomePod into a field, well out of WiFi range. With the HomePod running from a power bank the flash lost connection in about 8 minutes. Without the HomePod the connection remained until I got cold.
There may be multitude of possible sources of interference that could trip up these units but apparently only Canon devices trip up, other 3rd party units running the same RF protocol continue to operate normally.

I wrote to Canon CPS a couple of days ago and included links to this and another similar thread on this forum. So far they mentioned that they've never heard of this issue and asked to me to provide further information. I really can't provide more information than this thread already includes, but I'll continue to follow up on this issue.

A short time ago I read that Canon have postponed the release of the new EL-5 Speedlite. I've also just noticed that the 600EX-RT II has been discontinued (edit: it looks like the ST-E3-RT II has NOT been discontinued as I originally stated). This leaves only one native option for R3 and R6 II users and, unless I'm mistaken, leaving only the 430EX-RT III for the remainder of their cameras. It seems strange to discontinue the 600 while many of their cameras are still being sold with the old hot shoe. I can't help thinking....

I agree with you because of your testing, you have been able to prove that Apple HomePods are an issue for the Flash. The overall issue is the flash will drop the link, and no matter how much we tell Canon the issues, they always come back with "We've not been able to confirm this", or "We have not heard of this", and meanwhile we pay top dollar for the Canon flash hardware, with a flash system that fails to stay connected. Like I have said, Canon wins here with everyone buying their flash hardware, because most (like me) won't or can't send it back as it's out of the original warranty, and I had to buy 3rd party trigger/remotes just to make my Canon gear useable. #CanonFail 


I don’t have Apple Home Pods or Apple TV.