cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

600EX-RT trouble

KPIX2017
Apprentice

My 600EX-RT is dumping light on TTL. I've tried turning off modeling selection CF-2 and it is not set to multi. Every time I try to lower the power on TTL...it returns to the middle bar and is dumping too much light. I can set the power to -1, -2, etc...but the minute I press the camera's shutter, it returns to 0 on the +/- rating.

 

Suggestions? 

3 REPLIES 3


@KPIX2017 wrote:

My 600EX-RT is dumping light on TTL. I've tried turning off modeling selection CF-2 and it is not set to multi. Every time I try to lower the power on TTL...it returns to the middle bar and is dumping too much light. I can set the power to -1, -2, etc...but the minute I press the camera's shutter, it returns to 0 on the +/- rating.

 

Suggestions? 


That sounds like the result you get when you use a TTL flash on an E-TTL camera. A camera is either TTL or E-TTL, but not both. What camera are you using? Have you tried setting the flash to E-TTL?

Bob
Philadelphia, Pennsylvania USA

Canon5D, Mark iV...has been working fine until last shoot. Is this a setting I need to change on camera? or in flash? or both?


@KPIX2017 wrote:

Canon5D, Mark iV...has been working fine until last shoot. Is this a setting I need to change on camera? or in flash? or both?


I had thought it would be on the flash, but I just checked my 600EX-RT, and it doesn't have a TTL setting. Make sure it's set to E-TTL, but it looks like that isn't the problem.

 

I don't have a 5D4, but no E-TTL camera that I've ever used has a TTL setting, So make sure it's set to E-TTL as well. If both are and you still get the overexposure, I guess you'll have to Contact Canon Support.

 

With an E-TTL flash, underexposure is much more common than overexposure, in my experience. Apparently that's because the E-TTL algorithm assumes that all flash is fill flash, and concerns itself only with making sure that the highlights are properly exposed.

 

One other possibility: Make sure that you didn't inadvertently turn on flash exposure compensation. That allows you to call for a greater or lesser exposure than the camera's metering would select by default.

Bob
Philadelphia, Pennsylvania USA
Avatar
click here to view the gallery
Announcements