Canon Community Canon Community
 


Reply
New Contributor
Posts: 2
Registered: ‎04-26-2018

EOS utility not working

For whatever reason after a few days of not using EOS utility the software will not recognize my camera even if windows 10 does, I have turned off WiFi/NFC and connected it via usb but EOS utility does nothing with it. When I use EOS Utility 3 it just says "Connect an EOS camera." despite it already being connected. When I have used EOS utility 2 the software says "Camera is not recognized" when I launch the software and then connect the camera it immediately closes and gives that message as well.

 

Solutions Tried:

Double checking WiFi/NFC is disabled

Deleting the driver on windows and re-installing it (x10+)

Deleteing and re-installing EOS Utility 2 and 3 (x2)

Contacting support (they didn't seem to read my message and recomended me a solution I had already tried)

Giving up on life

 

Specs:

EOS Rebel T6

Windows 10 Home

 

I just don't know what else to do

Dang_(

VIP
Posts: 8,173
Registered: ‎08-13-2015

Re: EOS utility not working

Try a different cable.

----------------------------------------------------------------------------------------------------------------------------------------------------------

"I don't rent software. I use Photoshop CS6, ACR 9.8 and Lightroom 6.8 ."
Reputable Contributor
Posts: 904
Registered: ‎11-19-2017

Re: EOS utility not working

[ Edited ]

@Waddizzlewrote:

Try a different cable.


+1 what wadizzle said... 

 

Other possibilities:

-Plug USB directly into port on machine, not into a hub (if you are using one)

-Are you using a 3rd party AV?  If so, try disabling.  

 

If you are using Windows Defender for AV, thats not a problem.  

Rick
Bay Area - CA
~6D2 (f/w 1.0.4) ~16-35mm f2.8L II, 50 f1.8 STM, 85 prime USM, 70-200 f2.8L IS II ~70-300 USM II ~Sigma 24-70 f2.8 Art (f/w 2.02)
~Sigma 150-600 C + TC1401 1.4x (f/w 2.00) ~Speedlite 430 EX II ~DxO PhotoLab Elite ~Windows10 Pro1903 ~EVGA RTX 2080 FTW3 Ultra
New Contributor
Posts: 2
Registered: ‎04-26-2018

Re: EOS utility not working

It did not work

New Contributor
Posts: 2
Registered: ‎10-29-2018

Re: EOS utility not working

Remove the WiFi card from the camera then plug in and turn it on! If the Eos Utility doesn't come up, manually start it and it should recognize the camera.

 

This worked for my 7D MKII on both Windows 10 (Eos Utility 2 and 3) and my Macbook Pro 15" mid 2015 Sierra OS!!!

 

Hopefully this will work for many who experienced non detection and hours of online research and troubleshooting!!

 

:]

Occasional Contributor
Posts: 6
Registered: ‎01-05-2019

Re: EOS utility not working

I have the same problem and it's extremely frustrating. Used to work fine.  Uninstalled and reinstalled twice

 

It has nothing do with USB cables (2 cameras, two different ports, 2 different cables) and Windows beeps as it should when powering up and down.

 

It also has nothing do with WiFi as my PC doesn't have WiFI nor have I ever connected to either camera using WiFi. I think it just has that WiFi drodown because nothing else is working and it's grasping for options.

 

My guess is it has something to do with DropBox or OneDrive or Google Photos or someone else  grabbing the camera and not letting go.

VIP
Posts: 8,173
Registered: ‎08-13-2015

Re: EOS utility not working


@royanderson wrote:

I have the same problem and it's extremely frustrating. Used to work fine.  Uninstalled and reinstalled twice

 

It has nothing do with USB cables (2 cameras, two different ports, 2 different cables) and Windows beeps as it should when powering up and down.

 

It also has nothing do with WiFi as my PC doesn't have WiFI nor have I ever connected to either camera using WiFi. I think it just has that WiFi drodown because nothing else is working and it's grasping for options.

 

My guess is it has something to do with DropBox or OneDrive or Google Photos or someone else  grabbing the camera and not letting go.


Are you running a native installation Windows 10, or a Windows 7/8 upgrade to Win10?  

Sometimes you have to manually start the EOS Utility the first time you try to use USB.  For some reason, the EOS Utility seems to want to default to a LAN connection, which means it is not looking at the USB ports.  

 

There is an “EOS Lauancher” Utility that decides whether to launch the LAN Utility or the USB Utility.  The screenshot in the first posts shows the LAN Utility, but it also shows a message from a bad USB port/cable.

----------------------------------------------------------------------------------------------------------------------------------------------------------

"I don't rent software. I use Photoshop CS6, ACR 9.8 and Lightroom 6.8 ."
Occasional Contributor
Posts: 6
Registered: ‎01-05-2019

Re: EOS utility not working

I'm running the most recent version of Windows 10. The only way I can get the utility to start at all is to do it manually, at which point I get the screen with the "Connect an EOS camera." message. At this point both cameras, 6D Mark II and M50, show the connection icon on the menu screen.

 

Except for some transisition problems from V2 to V3 for my older 40D, I've been running the utility software for 10 years without any problems. Although becaise of all the devices I have it's been a long time since the utility woud autolaunch, but I've always been able to get it to work manually.

VIP
Posts: 8,173
Registered: ‎08-13-2015

Re: EOS utility not working


@royanderson wrote:

 


”I'm running the most recent version of Windows 10.”

 

“I've been running the utility software for 10 years without any problems.”


That is not exactly what I asked about your Windows 10 installation.  Your reply is irrelevant because Windows 10 will eventually update itself, irregardless of whether you want it to do so, or not.

 

Your complaints about the EOS Utility are consistent with complaints from people who are running Windows 10 on the older Windows XP/7/8 compatible hardware.  Windows 10 introduced security driven changes in computer hardware. 

Your second comments would seem to confirm my initial suspicion that you are using older hardware, which may not be fully compatible with Windows 10.  PCs that were built for Windows 10 interact with the computer hardware very differently from older machines.  People running older Acers, or PCs with non-Intel CPUs, are out of luck, and need to upgrade their PCs.

You may try launching the EOS Utility without a camera attached, and right clicking the icon on the Taskbar and selecting startup options.

----------------------------------------------------------------------------------------------------------------------------------------------------------

"I don't rent software. I use Photoshop CS6, ACR 9.8 and Lightroom 6.8 ."
Occasional Contributor
Posts: 6
Registered: ‎01-05-2019

Re: EOS utility not working

Hadn't heard there's any difference in Windows 10 installations or issues with old PC's.  Regardless, this PC is only 3-4 years old, Intel I7, and fresh Windows install.

 

I don't reboot very often, but I'd forgotten that that the aberrant EOS splash screen autostarts recently on bootup.

 

The only only options on right clicking the task icon are to turn on or off the auto launch when a camera is connected. Or Open which just gets me to the splash screen again, which does nothing (doesn't matter if a camera is connected or not). Surprisingly, changing the autolauch setting doesn't survive a reboot.

 

Not sure why this just started now. Only thing I've installed recently is the new version of ON1, but it doesn't have any background services that I'm aware of. Still think it's a software issue where something is blocking the utility from finding the camera - whether a Windows security change, or virus protection or one of the myrid of cloud and device apps that are capable of reading from attached devices.

 

Are there any Canon utilities to remove everything? Perhaps there's something damaged in the registry that's surviving a reinstall. Others such as Corel have them, but haven't seen one from Canon.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement