cancel
Showing results for 
Search instead for 
Did you mean: 

Canoscan 9000F One-Touch Buttons: What 'Registered Software Application' Do I Need?

PenaltyShots
Contributor

I have a Canoscan 9000F Mark II.  I'm trying to get the scanner buttons to work with it -- particularly the COPY button.  I've installed all available Canon software for Windows 7 (x64) for this scanner.  When I hit the COPY button, I get this dialog box:

 

Select the Program to Launch.JPG

 

So I went into the Scanner Properties for the scanner and found this Events tab.  But for every scanner button including COPY, it says "No application is registered for this event."  It won't let me select anything other than Take No Action.  The other choices are grayed out:

 

NoApplication.JPG

 

If I go to the original Canoscan 9000F (NOT the Mark II version) drivers and software page, I see this software called MP Navigator EX.  I installed that just for the heck of it, since none of the Mark II apps seemed to want to register as a "registered app" for this function.

 

When I did that, it actually put that as a choice (the only choice) by Start This Program:

 

mpex.JPG

 

I thought that would do the trick, but then when I hit the COPY button, I get this dialog box:

 

Mpnaverror.JPG

 

So I figure that MP Navigator EX is missing from the Mark II download page for a reason -- it's for the original 9000F and is not compatible with the Mark II.

 

OK...so...what IS compatible?

 

What app do I need to "register" for this buttons in order for them to work?

 

I'm completely stumped.  Someone please help; I'd greatly appreciate it.

 

-Thanks

 

 

1 ACCEPTED SOLUTION

Actually, that did not solve it for me.

But after a little bit of searching, I found out a solution that should always work - worked for me on my Canon Lide 120.

I thought I post this here, so that other people profit from it also - although I must say, I would expect Canon to come up with a decent piece of software that works reliably.

 

DISCLAIMER: What I am going to explain involves direct changes of your Windows registry. That's a bit like an open-heart-surgery. If you are not careful, you can break your system. Don't blame me, if that happens. 🙂

 

Background Info:

Canon ships a software called IJ Scan Utility. If you install the scanner drivers, this is installed, too.
This tool is supposed to fire up, when you press one of the scanner buttons. Once it fired up, it is going to execute one of the "rules" defined in Canon's quick menu settings, where you configure what should happen, when the buttons are pressed.

If all things were as they should be, there would be entries in your Windows registry that register IJ Scan Utility as a so-called Autoplay Handler for your scanner's buttons using the Microsoft STI Still Image Application API.

Since these registry keys are either missing or not properly set, I will describe how to do that manually.

A big thank you to Matteo Rossi, whose post led me to the right direction.

So, let's get started.

 

Solution:

  1. Backing up your registry!
    • Open up the Windows Start menu and type regedit. This will open up the registry editor.
    • Select the "Computer" entry, i.e. the root node of the registry.
    • Choose File > Export..., give a file name and export your registry. Note: this can take a while. The registry is big!
  2. Finding out the GUID and executable path of IJ Scan Utitlity. You will need that when we add registry entries.
    • Expand HKEY_LOCAL_MACHINE\Software\Canon\IJ Scan Utility
    • Copy the value of AppPath and InstallID to notepad or note them down.
      Find Out GUID.jpg
  3. Registering IJ Scan Utiltity as Autoplay Handler
    • Expand HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\AutoplayHandlers\Handlers
    • Right-click the Handlers folder and add a new entry. Call that entry WIA_{[InstallID from Step 2]}
      AutoplayHandlers Entry.jpg
    • Select the newly created entry, and add the following String-type fields on the right.
      • Name: Action, Value: Start IJ Scan Utility
      • Name: CLSID, Value: WIACLSID
      • Name: DefaultIcon, Value: sti.dll,0
      • Name: InitCmdline, Value: /WiaCmd;[AppPath from Step 2] /StiDevice:%1 /StiEvent:%2;
      • Name: Provider, Value: IJ Scan Utility
      • The result should look like this:
        AutoplayHandlers Entry.jpg
  4. Registering IJ Scan Utility as a Still Image Application
    • Expand HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Still Image\Registered Applications
    • Add a new String value on the right
      Name: IJ Scan Utility, Value: [AppPath from Step 2]
    • The result should look like this:
      RegisteredApplications Entry.jpg
  5. Adding IJ Scan Utility as STI Proxy Event Handler
    • Expand HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\StillImage\Events\STIProxyEvent\
    • Right-click on STIProxyEvent folder and add a new entry called {[InstallID from Step 2]}
    • Select the newly added entry, and add the following values on the right:
      Name: Cmdline, Value: [AppPath from Step 2] /StiDevice:%1 /StiEvent:%2
      Name: Desc, Value: IJ Scan Utility
      Name: Icon, Value: [AppPath from Step 2],0
      Name: Name, Value: IJ Scan Utility
    • The result should look like this:
      STIProxy Entry.jpg
  6. Save and close the registry editor.
  7. Restart your machine, since these changes might only take effect if Windows is restarted.
  8. Verifying that IJ Scan Utility is properly registered
    • After restart, log in and open Windows' Control Panel (German: Systemsteuerung)
    • Open the Device Manager and select Scanners and Cameras
    • Select the scanner, and Properties, then switch to the Events tab.
    • Select the respective scanner button event from the dropdown and verify that Start this program is set to IJ Scan Utility (if not, change it so it is)
    • Hit Ok.

That's it. You should be good to go now. And when you press a button on the scanner, whatever you configured in Canon's Quick Menu should be executed. E.g. if you press the copy button, the scanner should scan a document and then automatically send it to your selected printer.

 

Hope this helps.

View solution in original post

17 REPLIES 17

PenaltyShots
Contributor

Anyone?  Please, I'd really like to get an answer to this.  Pulling my hair out trying to figure out something that should be ridiculously simple.

 

Man, this is pathetic.  Will no one from Canon offer any help here?

 

What does it take to get an answer on this?

 

This is functionality that should be ridiculously simple to use.  It is advertised as such.  Just press the COPY button to copy a document, and so on.  It's proving to be impossible to get working.

 

Need some answers here, ASAP!

Hi, PenaltyShots!

 

If this is a time-sensitive matter, you'll find that contacting our US-based technical support team directly is the most efficient way to get the assistance you need.  We're standing by, ready to help 24/7 via Email at http://bit.ly/EmailCanon or by phone at 1-800-OK-CANON (1-800-652-2666) weekdays between 10 AM and 10 PM ET (7 AM to 7 PM PT).

We look forward to talking to you!

I'll try that.

 

Too bad you can't just answer the question here, though, for the benefit of others as well as myself.

 

So, I went through Canon Support. The rep not only had no idea how to fix the problem -- he first tried to deny that the problem existed at all, using phrases such as, "it SHOULDN'T need any other app in order to work," "you SHOULDN'T be getting that message from the Canon software," "it SHOULD work as long as you have the Canon Toolkit installed." Uh huh. Except that I obviously do, I am, and it doesn't.

He was also completely unaware that there are TONS of forum messages and other posts on the Internet about the same or similar problem. Tons of them. A Google search came up with 193,000 results. The rep said that this is the first time he'd heard of anything like this. Which means he's either lying or blatantly ignorant.

After about 45 minutes of repeating myself, and then finally pointing him to the pretty screenshots on this thread here (which he first, when I offered to give him the link, quickly dismissed as, "that won't be necessary,"), he finally decided that the problem was going to have to be escalated to the engineers.

That was a week ago. Most likely my request just went into the round file and was quickly forgotten. I'll be VERY surprised if I hear back again on it. Suspect I'll have to call again, get another rep, and go through the same stupid routine all over again.

Nice job, Canon. How about checking your forums once in a while? Do a Google search on this problem, for crying out loud. It's NOT an isolated case, by any means. It NEEDS to be fixed, and PRONTO!

Ridiculous.

Guess what? STILL no call-back from the supposed "second-tier engineers" to whom my support case was claimed to have been "escalated" nearly two weeks ago.

"Canon Support" is a complete joke.

Meanwhile, my Canon 9000F Mark II scanner, with its touted "One Touch" buttons that are supposed to make life so much easier, DO NOT WORK.

...And why, oh why, isn't there a dedicated SCANNER section on this forum? I, and hundreds of others, I see, have had to post their scanner problems here in the printer/multifunction (or some other) forum section. Why don't scanners get their own section?

It's 9 months ago. I am having the same problem today. Was alright with Win 7. With win 8+ it will scan but buttons do not function at all

I got my new 9000f MII today, buttons fail, after a lot of trying I picked up the phone. The support rep said in 90% of cases it's due to antivirus software. Yeah, sure. I offered to bet the value of the scanner that it's got nothing to do with antivirus, unfortunately she refused ... Anyway, I tried, made no difference ... Canon? Hello? Anyone?
Announcements

08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/28/2022: New firmware version 1.2.1 is available for EOS-R3
07/21/2022: New firmware version 1.6.0 is available for EOS-R5
07/21/2022: New firmware version 1.6.0 is available for EOS-R6
07/21/2022: New firmware version 1.1.0 is available for EOS-R7
07/21/2022: New firmware version 1.1.0 is available for EOS-R10
07/14/2022: New firmware version 1.0.1 is available for CR-X300
07/01/2022: New firmware version 1.3.0 is available for PowerShot PICK
06/30/2022: Service Notice: EOS 70D: Error 70 or Error 80
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!
12/7/2021: New firmware version 1.3.0 is available for Mount Adapter EF-EOS R 0.71x