Showing results for 
Search instead for 
Did you mean: 

Canon LIDE 210 Scanner Hangs


Sorry if this is in the wrong forum.. can't find a scanner specific forum


I have been using my LiDE 210 scanner to scan some photos.. and every once and a while, the scanner just hangs in the middle of a scan.  Totally locked up.  I have to use the Windows task manager to force it to quit.  After quitting the application (Canon MP Navigator EX)  and restarting it, it again freezes with a 'scanner warming up' message.  Even unplugging the scanner USB cable and replugging it does not fix the problem.  The only way seems to be to shut down my Windows 8.1 system and restart it. 


Any idea what may be causing this hang, and how to fix it?



People who has scanner hanging, can you please specify which motherboard/chipset do you have? Or if you use external USB controller, which model?


And, if scanner hangs on motherboard's port, does adding USB controller and switching scanner to it resolve problem?


I have lide 120 hangs on ASUS B85M-K


hi sergey, i have a  Gigabyte  B85M-D3H  i have tried different ports but the problem remains the same.

i think the key to the fix is that the scanner freezes >> you restart and during the closing down of the computer the scanner starts to react again.  so it seems there is a process going on that freezes the comunication. 


Since updating to Windows 10 my LIDE 210 freezes mid-scan if I try and scan above 150dpi. Which ever software I use I get various communication errors, and I have to restart the computer in order for another attempt.


I've tried a different cable, ensured that the scanner and USB drivers were up to date. All to no avail

For me The problem started in Windows 8. So its not specific for win10

Hi, I'm still running with Windows 7 and have the same problem!




Stop waisting your time and energy trying to solve this issue on your own.

Did waist far too much myself too.

Returned my Canon LIDE 210 and acquired an HP ScanetJet 300.

Installation = 10mn

Since then everything works perfect. 

Config = Asus Z170 Deluxe + W10 Pro







FYI - Since November Microsoft Windows 10 major update, my scanner works everytime.  I hope others are having the same experience.



my w10 pro version was installed last week Wednesday with latest Microsoft, Asus and Canon updates and i however faced the same poor situation than hundreds of common Canon customers.

Did Microsoft issued a major update in between Wednesday and today ?

whiich configuration are you running ?


I have been getting 2, 156, xx errors on Windows 10 for a few weeks now. I replaced my previously faithful old LIDE 210 with a new LIDE 220 but continued to get the same problem. The scanner makes noises and starts to scan but then freezes, sometimes a few pages in, sometimes on the first page.


Since I could find no evidence of a crash in Windows logs, I figured that it was a pure hardware problem, perhaps with the USB power to the scanner. The scanner stops moving and Windows suddenly doesn't know the scanner is there: just like someone pulled out the plug.


So, I wondered how the scanner would behave when my laptop was not plugged in to the mains and was running on battery power. Would the reduced power make the freeze happen sooner? To my surprise, no!, running on battery I can scan as many pages as I want without any problem. Plug the computer in again and the scanner freezes on the next page.


Next I tried scanning with the computer plugged in but after changing my Windows power plan to "Power saver". Again, no freezing. After changing back to my usual power plan, the scanner freezes.


Unplugging the laptop seems to have worked through through turning on some of the power-saving features.


I have tried to identify which of the power-saving features makes the difference. But trying each feature individually doesn't seem to do the job; it needs a combination.


I have now set up a new power plan which makes the laptop use the same power-saving features that are engaged when I unplug my laptop (with the exception of basics such as changing screen brightness, sleep times, etc.) even when it is plugged in. I have written a handy little .cmd file that toggles between the two power plans, can be accessed with one tap on my start screen, and reminds me to change back to my usual power plan once I have finished scanning.


I've been scanning for the past two days without any trouble.



In short, what do suggest you try?


1. If you are using a laptop, temporarily switch to the "Power saver" power plan.


2. If you are using a desktop, you may need to create a new power plan and (perhaps) use "Change settings that are currently unavailable" to access the power-saving options. (I haven't tested this scenario.)



I just wish I had figured this out before buying a new scanner. (If Canon would like to reward me for doing their work for them, I am going to need an imageFORMULA DR-C225W soon.)

Thanks. That solved the problem for me. Canon LiDE 210 now works on my Surface Pro 4 under Windows 10.


Canon, if you are listening, hope to get an updated driver soon.

06/30/2022: Service Notice: EOS 70D: Error 70 or Error 80
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version is available for EOS-C500 Mark II
05/26/2022: New firmware version is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version is available for EOS R5 C
03/23/2022: New firmware version is available for EOS-C70
03/22/2022: New firmware version 1.2.0 is available for PowerShot PICK
03/16/2022: New firmware version 1.5.2 is available for EOS-R5
03/16/2022: New firmware version 1.5.2 is available for EOS-R6
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.1.1 is available for EOS-R3
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!
12/7/2021: New firmware version 1.3.0 is available for Mount Adapter EF-EOS R 0.71x
12/7/2021: New firmware version 1.1.1 is available for CR-N 300
12/7/2021: New firmware version 1.1.1 is available for CR-N 500
12/2/2021: New firmware version 1.1.0 is available for RF 70-200 F4 L IS USM