Showing results for 
Show  only  | Search instead for 
Did you mean: 

iPF6300 prints now coming out dark


Used to get great, accurate prints with PS3- "Photoshop manages colors" - now, with Mac 10.8.3 and the latest printer firmware (following an expensive printer rebuild and a new Mac) my PS images come out too dark.  I was taught and, with long experience agreed, that messing with "printer manages colors" and playing with color adjustment was less accurate.  What's wrong here?



Be sure that you have turned off the printer manages colors in the printer driver. You need to choose "No color management" in that printer driver.(i.e., On the main page of the printer driver, select advanced settings. Also, after that, under "Color mode", choose "No color correction").  Also, set the media type to what you are printing on, in the printer driver menu.(such as Canon glossy).

In the Photoshop "print" command menu, choose "Photoshop manages colors".  Choose the icc profile that is matching the paper that you are actually printing on.(such as Canonglos.icc or whatever the profile is that is correct for the paper you are printing on).

Choose rendering intent, usually the icc profile guides you on that, but try perceptual and do check by black point compensation.

Hope this helps.


Thanks for your reply, Debra. Your list exactly follows the proceedure I was taught.  I've got the ICC profiles for the Premium Satin RC paper I'm using and have PS3 doing the managing in PS3 as well as the Canon driver, black point compensation and all the rest.  Your recommendations are chapter and verse, to be sure, and have always worked before, that's what's confounding me.  Thanks for your time, concern and help.

I would go to the color settings in the printer driver and make sure everything is set to zero. I would then let the printer manage colors and print a small sample image and see what you get(uncheck "Photoshop manages colors" and set the printer to manage colors in the printer driver.) Then, after doing that, shut it down and restart your machine. Then open that image again in photoshop. Go into the printer driver and change to photoshop manages colors. Go to the printer driver and set no color adjustments.  Then select the icc profile in the photoshop menu to print, and try that. It may need this type of setting and then resetting.  I have heard of stranger things. I would try this.