cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Trying to print from My Image Garden; get msg "An internal error has occurred"

Jake460
Apprentice

I can't print from My Image Garden (v2.0.1),  I either get "An internal error has occurred" or the program hangs.  I run WIndows 7 64 bit.  I can print to the Pixma Pro-100 from other programs.

9 REPLIES 9

Ebony
Rising Star

Hello Jake460,

 

Have you tried reinstalling the application from the website? If not, click HERE to download My Image Garden and let us know what happens.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

I uninstalled the version of My Image Garden that came on the set up CD.  Then checked the registry for errors - deleted keys for My Image Garden.  Then downloaded the latest version of My Image Garden from the Canon site and installed same.  

 

My Image Garden still stalls when I try to print.  Sometimes I get the internal error message, sometimes I don't.

Hello.

 

Additional troubleshooting will have to be done to narrow down the cause of your issue.  Please contact our support group using the link below for additional assistance.

 

http://www.usa.canon.com/cusa/consumer/standard_display/contact_us_consumer

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

I am also experiencing this error message - Mx922, windows 7 - I have followed all directions in this (and other Canon) threads and nothing has resolved this issue.  WiFi is connected - printer works fine - I just cannot  get the newly re-installed My Image Garden shortcut to open the program (same goes for Quick Menu shortcut).  When I try to scan from the multifunction device, I get the "An internal error has occured".  Help?

CoachRob
Apprentice

I get the same intermittent problem when I try to scan via Image Garden. The whole thing freezes and I have to reboot to try again.

How is it possible for Canon to sell a printer/ scanner that fails to scan. I too have downloaded the new driver without success. It scans a few photos and then fails.

What's the solution, Canon? Return the printer as unfit for purpose?

Any progress on this?

reneplante
Apprentice

This is a bunch of crap...Canon software is crapware.  I have been fighting this issue and finally uninstalled the Image Garden software and now the scanner works fine.  I replaced my 800 series with the 920 series and it is no where as good as the 800 but the 800 just quit printing.  Sorry but it really pisses me off when overprices companies like Canon are so screwed up.   Go to Start in lower left corner of the home screen. Click on Start then open Control Panel then click on uninstall programs then find Canon Image Garden and uninstall.  I did this and then scanned a new item and it worked fine.

I have been getting the same error for a long time. Recently I noticed that, as default printer, My İmage Garden has chosen "Canon iP7200 Series WS" whereas my default printer was "Canon iP7200 Series" (without WS) I changed it to my default and the problem solved itself.

Failing that, you can always use a cable connection. It works under any condition.

Avatar
click here to view the gallery
Announcements