Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon pro-100 firmware upgrade from 1.1 to 2031


I havent been using my printer so i haven't been doing my firmwares updates like i should.  I missed 1.2 and 1.3, now i want to update it to the latest firmware and it keeps giving me an error.  I have tried my windows 10 and windows 7 and  both are giving me the same error while updating the firmware.   it shuts down the printer mid way and says it cannot connect to the printer.  no data transfers.   drivers are installed on the computer and it works, and it can print.  i just want to update the firmware.  If someone can kindly help me with this, thank you in advance.

111 REPLIES 111


Are you using a USB cable to flash the FW?


This updater will upgrade your printer's firmware to version 2.031. To perform this upgrade, a USB cable and a computer are needed. If your printer's firmware version is already 2.031 or later, the update is not necessary. To check your printer's firmware version, refer to the Update Procedure included in the downloaded file.


We cannot tell from your post what method you are using. 

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

As mentioned above, you need to use the USB cable. I upgraded my firmware yesterday and (on a Mac) the installer was explicit with those directions. 


To check your firmware version put a piece of paper in the rear (top) tray and then press the resume button until the light blinks twice. That will cause the printer to print out a sheet that contains the firmware version.

yes, i am hard wired to the printer using a cable. i did it to both windows 7 32 bit and windows 10 64 bit. both failed.  The printer is on, then I can hear the computer acknoledge the printer is turned off during the process and then it gives me an an error.  the process shuts down my printer.  i belive the issue is that i do not have 1.2 installed.  you thinK this is the issue? i have even made sure that the printer is using the cable by checking the canon IJ network tool.


I just did the paper feed and hodling the resume and it printed out 2 columes with the colors of my print cartridges and with Ver. 1.100 on it.

Same problem with W10 and 1.1.


Process starts, Printer flashes three orange lights, then the process aborts.


Also tried with MacBook Air running Catalina - same failure.

John Hoffman
Conway, NH

1D X Mark III, M200, Many lenses, Pixma PRO-100, Pixma TR8620a, Lr Classic

My PRO-100 is normally connected to my Windows 10 PC (64-bit with all the latest Windows Updates) via WiFi. Before I updated the firmware this morning, my PRO-100 firmware version was 1.100.


I downloaded the updater, then connected the printer to the PC using a long USB cable. The firmware update proceeded as advertised, with no error messages. After the update, I disconnected the USB cable, unplugged the AC power, plugged the power back in, and powered on the printer. I did a nozzle check, which also prints the firmware version, and the firmware version now reads Ver. 2.031.


As a final check, I printed one of my photos, and everything appears normal. I didn't notice any particular improvement or change, either, but I don't seem to have broken anything.


At least with my setup, the firmware update appears to have been successful. 



yes, i am using a usb cable. it's at version 1.1.  


Tried the following (W10 computer setup):


1. delete and reinstall printer driver


2. turned off wifi


3. printed a nozzle check.


4. run the updater - process starts, then I get the Windows sound for a disconnected USB device, then printer starts flashing three orange lights (which relates to incorrect position of paper trays- I know thats wrong becasue i just printed nozzle check), then installation aborts. After error message clears the computer beeps againg and printer is reconnected.


5. When I go to use the printer the next time after the update failure the first thing it does is eject a page.


For the folks who got it to work - can you see what it is doing? Description is pretty vague.

John Hoffman
Conway, NH

1D X Mark III, M200, Many lenses, Pixma PRO-100, Pixma TR8620a, Lr Classic

@jrhoffman75 wrote:


For the folks who got it to work - can you see what it is doing? Description is pretty vague.

When I updated the firmware, there was nothing much to see other than what the updater told me I should see. Before running the updater, I connected the printer to the PC using a long USB cable (it's normally connected only via WiFi). I never turned off WiFi, it was on during the entire update process and it didn't seem to make any difference.


When I clicked the "Start" (or similar) button, the progress bar gradually moved from left to right, and at the end, the display changed and told me the update was successful. The printer never showed any orange lights, at least none that I noticed. At the end of the process, as described in the updater, the  printer powered down. Then, as instructed, I disconnected, then reconnected power. The printer came back to life and all was well. At that point, I removed the USB cable, and I was still connected to the printer via WiFi. I did a nozzle check to see the firmware version, and the sheet reported 2.031. I printed one of my photos (via WiFi), and everything worked fine.


A couple of details I remember:


At one point near the beginning of the update process, I'm fairly sure I heard the USB disconnected sound, a few seconds after which I heard the USB connected sound.


After the firmware update (and after I removed the USB cable), I visited the Printers & Scanners control panel. The installer warned that there could be an extra printer in the list after the update, something like "Canon PRO-100 Series Copy 1" (I forget the exact name). The installer advised that this extra printer in the list could (and probably should) be deleted. I did find an extra Printer in the lst and dutifully deleted it. I then successfully used the original "Canon PRO-100 Series" printer for printing a photo from Lightroom (using the Canon Print Studio Pro plug-in).



I am having the same issue like hrhoffman75


click here to view the gallery