cancel
Showing results for 
Search instead for 
Did you mean: 

imageClass MF4890dw driver not working correctly with Mac OS Mojave

AmberJ
Apprentice

Hey there,

I am trying to set up the imageClass MF4890DW on my Mac running Mojave. The printer is connected via USB and was recognized, but needed a driver. I downloaded the correct driver from the Canon website successfully. Emails print fine, but PDFs do not. If you try to reconnect many times you may get it to print, but may not. I've removed and reinstalled the printer several times to no avail.

 I have been using this printer for years (kudos to a great product), and have used it with Mojave before. It worked with my High Sierra computer, and even subsequent OS upgrades without ever downloading a new driver.

Is it possible that there's a problem with the new driver? Hope you can help!

Thanks, Amber

2 REPLIES 2

Hector
Product Expert
Product Expert

Hello AmberJ,

If you are using Mojava and have already download and installed the MF Printer Driver & Utilities for Macintosh V10.11.8 [OS X 10.11.6 - macOS 12.4] from our support site and have deleted and added the printer, the correct driver should be installed. If you are just having problems printing PDF files, there is a chance that the PDF viewing/editing software that you have might need to be updated. I would suggest checking for any updates or to try printing the PDF from a different program on the computer to see if you have problems printing from there as well.

We would be happy to assist with the issue. To provide some feedback or some troubleshooting steps, we would need some additional information. If you could reply to this message with the information below, we can provide some assistance.

  1. What program are you printing the PDF files from?
  2. When you try to print the PDF files, do you get an error or what happens?

Hi Hector,

Thank you for your response. I am trying to print pdf’s from the Apple preview program and from the UPS website. The error that I get is “filter failed”. Sometimes I can refresh the print job and it will print, but 9 times out of 10 it won’t work at all. 

I have also reset the printing system as suggested by Apple. That worked for one job and then the error message came up again. 

Do you by any chance have an older driver? This printer had worked fine on this computer with the same operating system but then I changed printers for some time and now it’s not working. Nothing has changed except the new driver. 
Thank you again! Amber

Announcements
09/19/2022: New firmware version 1.0.4.1 is available for EOS C70
08/31/2022: New firmware version 1.1.1 is available forRF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/28/2022: New firmware version 1.2.1 is available for EOS-R3
07/21/2022: New firmware version 1.6.0 is available for EOS-R5
07/21/2022: New firmware version 1.6.0 is available for EOS-R6
07/21/2022: New firmware version 1.1.0 is available for EOS-R7
07/21/2022: New firmware version 1.1.0 is available for EOS-R10
07/14/2022: New firmware version 1.0.1 is available for CR-X300
07/01/2022: New firmware version 1.3.0 is available for PowerShot PICK
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!