cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

imageCLASS LBP6030w Firmware Not Updated for Mac Sonoma 14

Clueless1
Apprentice

Exactly as the title states.  I tried setting up my printer today with a time sensitive document I needed to print, and after noticing that my old printer has run out of ink, I decided to finally install the imageCLASS LBP6030w.  Downloaded the driver and installed it. Downloaded the firmware only to have it state: "The developer of this app needs to update it to work with this version of macOS. Contact the developer for more information." Tried looking everywhere for a contact number for Canon, and I come to find out you basically can't contact Canon directly. Such a headache. Any help would be appreciated.

0 REPLIES 0
Avatar
click here to view the press release
Announcements