Showing results for 
Show  only  | Search instead for 
Did you mean: 

Windows 10 doesn;t find MX922 after changing internet


I changed from Comcast to Metronet internet service.  MY MX922 printer/scanner was working well before the change.  Now I can't get Win 10 to find the device.  I've tried both wireless and ethernet router.  After an hour with a Canon tech we did finally get the MX922 to print a Network Configuration Page showing an IP address and using CMD.exe I can ping the device at

The Canon IJ Network Tool fails saying:

"There are ports that cannont be used with their current sesttings.  For details refer to the [instructions] to be displayed automatically."  The printer does not appear in the port list.   

In the listing of ports, another network printer that is working shows up.  Windows Control Panel does a search and fails to find the device.  

I've also tried hardwiring to an ethernet router and it still won't connect. I really need the scanner for the autofeed of documents.