cancel
Showing results for 
Search instead for 
Did you mean: 

TS8320 won’t connect to wifi network

Bev2
Apprentice

The printer direct connects to my phone. However, neither my MacBook nor my iMac can find it. The printer won’t connect to my wireless network.

The Wi-Fi setting list says:

Connection   Enabled (disconnected). 

Then it gives a Network name (SSID), Frequency 2.4GHz, WiFi security Disable, Signal strength 0, several lines with no data, then gives a MAC address, a Printer name, and a Bonjour service name. 

I have unplugged the printer. I have reset all the settings to factory default, I have moved the printer next to the router. I have restarted both computers. Both are Apples running OSMonterey 12.2.1. 

The printer was connected and working fine until I had an Apple technician (it went to the Genius Bar) reformat my hard drive to get rid of some remote viewing software my ex-husband had surreptitiously installed.

Since getting my computer back, I have had this problem. 

Please help! I have documents I need to scan and email to the government.

Thanks so much! 

 

3 REPLIES 3

irishpadres
Apprentice

That's strange. I'm having the same issue. No changes to my network and the printer has been running fine for over a year. It just all of sudden can't connect to my network.

irishpadres
Apprentice

@bev2, what is the brand of your wifi network device. I'm using an Eero. I'm wondering if there is some commonality there.

Hi @irishpadres. My wifi is through AT&T. I tried manually connecting. Had to go to the ATT website to find my Mac No. then it didn’t match any of the options offered on my printer. I tried a couple of the options offered and one finally worked. The scanner wouldn’t work with my iMac either, after the last iOS upgrade to Monterey 12.1.2. Had to go to Hamrick and pay $20 to download a driver. Better than buying a new printer, especially since I have almost 3 full boxes of toner cartridges. Best of luck! 

Announcements
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
03/22/2022: New firmware version 1.2.0 is available for PowerShot PICK
03/16/2022: New firmware version 1.5.2 is available for EOS-R5
03/16/2022: New firmware version 1.5.2 is available for EOS-R6
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.1.1 is available for EOS-R3
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!
12/7/2021: New firmware version 1.3.0 is available for Mount Adapter EF-EOS R 0.71x
12/7/2021: New firmware version 1.1.1 is available for CR-N 300
12/7/2021: New firmware version 1.1.1 is available for CR-N 500
12/2/2021: New firmware version 1.1.0 is available for RF 70-200 F4 L IS USM