Showing results for 
Show  only  | Search instead for 
Did you mean: 

Pixma MX920/922 reset LAN settings


After changing wifi networks, my printer sees the new network, tries to connect, but fails.  It never asks me for the passphrase after I select the network, which leads me to believe it's using the old password from my old network.  I performed the "Reset LAN settings" in the device settings menu, but it still won't prompt me for the password.  Is there ANY way to change the wifi network password on this giant paperweight?




If you re-run the set up program, it will give you the option to update/change the Wi-Fi network and/or password for the network.  This will allow the printer to connect to the new network.  

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

I have re-run the setup program, several times.  I've "Reset LAN settings" and "Reset all", then run the setup. I use the "standard setup", as my new network - a T-Mobile gateway hotspot - doesn't have a WPS feature.  It finds my home network, no problem.  But when I select that, it shows "searching for access point...".  After 10-15 seconds, and no password prompt, it beeps and replies with


Failed to connect to the access point.

Follow the steps below.

  1. Check that the selected access point is correct.
  2. Check that the entered passphrase is correct.
  3. Restart the access point..

If the same error occurs, see the access point manual and check the settings."


I've tried wireless - which worked fine with my old network, and also USB wired.  There's never a prompt to enter the new password.  So, either it's still using my old networks password, or isn't detecting that my new network requires one.  I've had this new T-Mobile gateway for a couple of weeks now, and every device in my home connects to it no problem, so it's not that.  I just need some way - that actually works - to completely reset reset the printer.  The "Reset LAN" and "Reset all" haven't worked.  Also, Canon seemed to go out of their way to delete ANY drivers or setup programs from their website for this model, and won't talk to me at all unless I pony up more cash.  I guess they figure if I have to buy another printer, it will be a Canon...?  Uh, doubtful, given the customer service - or lack thereof.


Hello there!

You can find your personalized support options within your My Canon Account at

I am not a tech, but I have some experience with T-Mobile Home Internet, and this sounds like it's an issue of your T-Mobile Internet Gateway not being able to see your printer. 

Your printer can only see 2.5Ghz networks, so you need to make sure your T-Mobile Home Internet (TMHI) is broadcasting both networks, so open the T-Mobile Internet app and tap the Netowrk tab along the bottom. You'll see your WiFi name along with Frequency band "5Ghz, 2.5Ghz, or Automatic" - for the printer to be seen, it needs to say 2.5 or Automatic. If you want the fastest speeds, put it on Automatic. If it's broadcasting both networks, then should be good.

Now that you've done that, you should be able to follow THIS article to manually connect your printer to your T-Mobile Internet Gateway.

My T-Mobile gateway is set to "automatic" (has both 5Ghz & 2.4Ghz).  My printer is seeing my network. My network shows up right away, at the top of the list, so the printer is seeing it.  The problem is that when trying to connect to the network (which it never has) it doesn't prompt me for the password.  The password has never been entered on this printer, so it needs to be, in order for it to actually connect to my password-protected network.  If the printer setup won't give me an option to enter the network's password, how can it connect?

follow THIS article to manually connect your printer to your T-Mobile Internet Gateway.


Yes, those instructions are exactly what I've been doing.  Over and over.  But, in those instructions, as in all others I've found,  selecting your network brings you to an alpha-numeric password-entry page.  When I do this, that password-entry page never appears.  What I need is a way to enter the password, an the normal printer setup won't let me do that.


I am having the same experience.  In my case, I changed the password of my T-mobile home internet gateway and now need to make the same change on my MX920 printer.  The printer just fails to connect just like yours and never allows me to enter the new passcode.....

Yeah, it sounds like no one - not even Canon - has any clue of how to manually enter the wifi password into the printer settings when the auto-process won't do it.

I gave up.  I bought an Epson to replace it.  Works great.  Too bad, as I had been a Canon man (printers and cameras) for decades.